RAZER Core power on

Discussion in 'Systems' started by iamsteve17, Feb 9, 2017.

Thread Status:
Not open for further replies.
  1. systemBeigesharp234

    systemBeigesharp234 New Member

    Hey has anyone had this problem...
    when I plug in the Thunderbolt cable I hear a click inside the core but nothing happens.

    The first time I connected the core it worked fine and was stable all day, the second time it took 3/4 attempts to connect, today it simply wont power up.

    Anyone got any suggestions or have experienced similar symptons?

    cheers

    Blade 2016 1060 plus core with GTX1080
     
  2. AngelSoryu

    AngelSoryu New Member

    Hi there,

    I've had this issue, and it scared me to death. I don't know if this will work, but give it a try.

    Try to unplug the core power for a minute (Not 5 seconds), and restart the laptop. If you plug into a power strip, unplug that as well. Sometimes, it seems like the core won't work correctly on 'my' box when I've had it plugged in for awhile without it being connected to the laptop.

    There are also suggestions and guides on insider regarding the magnetic mechanism that tells the core that it's closed and ready. I don't remember who posted that info, but it's worked for others in the past.

    Good luck!
     
  3. systemBeigesharp234

    systemBeigesharp234 New Member

    Thanks for the advice, ive just tried what you said and no joy. when you plug in the TB3 cable you can hear a click, as if its trying to power up. but then nothing happens.

    i also read about the magnet connection and i cant see what needs to be adjusted unfortunately. this is so frustrating it worked perfectly well to start with. im waiting for the razer support team to get back to me so hopefully they can help.

    thanks again
     
  4. Yousif47

    Yousif47 Active Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >