Razer Core Problems and Solutions

Discussion in 'Systems' started by Brisingr_Phoenix, Feb 27, 2017.

Thread Status:
Not open for further replies.
  1. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    I've seen a lot of people on this forum asking for solutions on the same issues with their core and RMA-ing for problems that could be easily solved, so I decided to just make a single thread with all of the solutions I've found work with my setup.

    For reference, my setup is the Kaby Lake RBS 512GB QHD and Core with a GTX 950 SSC.

    Without further ado, here is my Razer Core for Dummies post:


    1) USBs not working

    -Before you make any assumptions use any standard flash drive and take turns plugging it into each individual USB slot, if there are any slots in which your system does not correctly utilize the drive: you’ll know what to do

    --Make sure that you give the system a minute or two to recognize the device before going onto the next one

    --Prior to using a given USB make sure to confirm that it actually works, and that you already have the drivers downloaded

    -Usually this can be caused by the cumulative power drain from all of your USBs being too great while it is under load. I’ve seen a similar issue happen when having all of my peripherals plugged into the same hub, the USBs would constantly disconnect at random.

    -Turn off USB *selective suspend

    2) The Core isn’t plug and play?!? (or Core otherwise not being recognised upon plugging in)

    -This can usually be solved by doing a simple power cycle on the Core. Usually this consists of unplugging the Core (make sure to wait around 30 seconds before plugging it back in), then plugging it back in

    --To streamline this process, I found out that you can also just turn off the **Core’s power supply (following the 30sec rule), and turn it back on

    ---Most of the time I have the Stealth plugged in while doing this, but the times I’ve had it unplugged it has worked just fine

    ----Make sure that you have the prerequisites downloaded for your given system

    --On Kaby Lake systems all you need to do is download your GPU’s matching drivers

    3) External Monitors having stuttering effects

    -Note that this issue only seems to affect those with 144hz monitors, 60hz monitors seem to have no issues (or none I can find)

    -Plugging the monitor directly into the Stealth is a possible workaround, but users will be limited to a max of 60hz

    -Putting your display in extended mode can counter this issue

    -Some users have found that plugging the core in after booting the system up can counter this issue, this could allow a user to have their laptop screen off while gaming without the monitor stuttering at the same time

    Issues experienced mainly by First Gen users:
    (or solutions that only apply to it)

    1) Core not being recognised upon plugging in or disconnecting constantly

    -You need to download both the Graphics Drivers and update your BIOS before using the Core for the first time

    -You may have to shut down and Restart with the Core plugged in

    *Located in Control Panel -> Hardware and Sound -> Power Options > Change Plan Settings(on whichever plan you are using)-> Change Advanced Power Settings -> USB Settings -> USB Selective suspend

    ** Power Supply can be found by pulling out the GPU chassis and looking for an on/off switch located on the side opposite of where you would put your GPU (video coming soon)

    Author notes: Any other issues/solutions are brought to my attention will be edited into the post If there are certain issues that have no solutions or workarounds they will be added to the list, but will contain a “Contact Razer Support” in the solutions section
     
    Last edited: Mar 1, 2017
    CedricE, surfer1081, Destrok and 2 others like this.
  2. Destrok

    Destrok Well-Known Member

    Great post! Just stickied this in the systems forum for the time being, hopefully it helps some people out.
     
    Brisingr_Phoenix likes this.
  3. jaseow

    jaseow Active Member

    My core recently decided to start diaconnecting randomly. It would disconnect for a second or 2 then come back on on.

    You can hear the fans stop then start back up and the lighting goes off during that time as well.

    Of cos whatever game / program im using at that time will crash and I have to relaunch it.

    As you can probably tell, it gets old and bothersome real fast as it can happen every 5 mins to 20 mins. It is really random and no way to predict when its going to happen
     
  4. Unfortunately, the USB issues on the Razer Core are more severe than that (both Cores I've had work marginally with one USB UI device connected until you put the ethernet port under load, but USB fails completely with more than one connected) The latest word to me from Razer support is to use an external 3.0 USB hub while they figure it out.
     
  5. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    The reason I have the USB solutions there is because it’s more of a trial-and-error test that you could do before accidentally RMAing a Core that could possibly have nothing wrong with it.

    I’ve had that problem before, if I may ask: do you have the First Gen RBS or the Kaby Lake one that came out late 2016?
     
    Last edited by a moderator: Feb 28, 2017
  6. Good point. I think it's important to check that a USB device works on the laptop, I don't think there have been any issues with that, so that's a good way to test if it's the Core or simply a problematic USB device.
     
    Brisingr_Phoenix likes this.
  7. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    Thanks for the praise :blush:, and to add onto razer's recommendation I would suggest getting a USB hub that has a dedicated power source (if you're using a good amount of peripherals)
     
  8. jaseow

    jaseow Active Member

    First Gen i7-6500u stealth QHD screen
     
  9. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    I see... So when I had that edition I would continuously experience that and the only solutions that I could find would be power cycling; if that didn't work I would then restart with the core plugged in, open any game, wait for half an hour with the game open on the menu or something, if the game didn't crash within that time period then I knew that I could continue playing with little issues
    The reason the first gen stealths work this way is probably because the final architecture of the Core wasn't completely flushed out until after the RBS was first shipped, which is most likely why First Gen users have to jump through more hoops (such as downloading a bios update) in comparison to Kaby lake users. This is just speculation though.
    Anyways: I hope this helps!
     
  10. jaseow

    jaseow Active Member

    I never had this problem in my first 4-5 months of usage though. It only started recently. Also it doesnt make sense that I have to keep power cycling the core and wait for 30 mins to see if I can play a game properly.
     
  11. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    I mean- that's what I found worked since I realised that if it didn't go out within the first 30 mins of booting it up: it would be less likely to happen during that given session. That's just me though, it could also be because of the drivers you have installed currently being finicky. I've seen as many issues with for this specific system and as much of these issues only being experienced by a handful of people at a time. This being said: I'll do my best to find some more solutions for that problem and update my post accordingly
     
    Last edited: Feb 28, 2017
  12. Brisingr_Phoenix

    Brisingr_Phoenix Active Member

    Update: Made a section for issues that are mainly being experienced by those that use the first gen RBS and moved it's solutions to this section
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >