Razer Core USB says it disconnects

Discussion in 'General Discussion' started by about4penguins1, Jul 9, 2016.

Thread Status:
Not open for further replies.
  1. I do not have a have a graphics card currently in the razer core. Randomly it says that the usb you connected malfunctioned and cannot be recognized but the lights on the Razer Core still work so i assume that it is still up and running, obviously I cant check since I do not have a card in it. Does anyone else have a problem like this?
     
  2. mintouch

    mintouch Active Member

    I had suffered from same problem while I used my Blackwidow X Chroma and Mamba wireless. But after the manual update with using Razer Blade Stealth updater(including BIOS update plus Thunderbolt driver update), It works flawlessly.
     
  3. This should help:
    A) Reset the graphics card, then secure the cable connections within the Core.


    B) Restore BIOS settings to default

    1. Power on your laptop via AC adapter and immediately spam the F1 or Del key until the BIOS menu loads.

    2. Select ‘Save & Exit’, then select ‘Restore Defaults’. When prompted, select ‘Yes’.

    3. Select ‘Save Changes & Exit’. When prompted, select ‘Yes’.


    C) Perform system recovery, as the issue may have originated from Windows.

    1. Please backup your files as it will be erased in the process.

    2. Power on your laptop via power adapter and immediately spam the F9 key until the recovery menu loads.

    3. Select ‘START RECOVERY’ and follow the on-screen instructions. The process could take around 20 minutes to complete. You will have to reconfigure your laptop after the process is completed.


    D) Connect your laptop to the internet using an Ethernet cable or a 5GHz band wireless network. Please do not connect your laptop to the internet using a 2.4GHz band wireless network.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >