Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Core - Windows 10 Lag/Choppiness

Discussion in 'Systems' started by Cyraxus, Jul 7, 2016.

Thread Status:
Not open for further replies.
  1. Cyraxus

    Cyraxus Active Member

    I'm wondering if anyone is seeing the same thing I'm seeing. I got my Core yesterday and installed a 1070 card in it. I'm using it with a Razer Blade 2016. After following the instructions Windows definitely recognized the Core and graphics card but Windows is very choppy. When I click on the start button and do basic things like click the notification center there is lag.

    I thought maybe it was because I was using the USB ports and Ethernet on the core so I unplugged all of that but I'm still getting choppiness/lag in Windows.

    Has anyone else experienced this?
     
  2. SeaBlueurbanbase835

    SeaBlueurbanbase835 New Member

    I don't have the core yet, but have you checked your Nvidia control panel?

    Maybe in the global settings it's still using the integrated Intel graphics
     
  3. Lots of people are having this issue, myself included. Ive heard everything from buy USB hubs to install the latest drivers...... Nothing has worked for me. The other issue I have is my Razer Ripsaw capture card is completely bricked on the stealth + core.
     
  4. Cyraxus

    Cyraxus Active Member

    Yeah It's annoying. It's definitely not a USB issue for me because I don't have anything plugged into the USB ports on the Core. I definitely have all the drivers up to date. What's strange is that games run fine. No choppiness or Lag. It's just in Windows. So weird.
     
  5. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Does it work properly when you boot with the core attached? How about if you run with the laptop's screen open and set to "extend"?

     
    Cyraxus likes this.
  6. Derek712

    Derek712 Active Member

    I've asked Razer directly about this. They responded and asked for more details. Hopefully I hear back on Monday.

    I've found that if my laptop screen is active, I don't see any choppiness at all. It must be set as an extended desktop, not duplicate screens. I'm interested to see if this temp fix works for everyone and not just me.
     
    Cyraxus likes this.
  7. Cyraxus

    Cyraxus Active Member

    Interesting. I'll try that. Let me know if what response you get from Razer since they won't help me.

    This definitely works better. Having the laptop screen as the extended display fixed the choppiness. Hopefully Razer is working on a fix. I'm wondering if it has anything to do with the Pascal cards. I'm not seeing anyone complaining about this that doesn't have a 1070 or 1080.
     
    Last edited by a moderator: Aug 5, 2016
    Derek712 likes this.
  8. The issue does not exist for me when I extend displays.

    Razer support had me update the Stealth drivers from the website. This did not change my lag....
     
  9. Derek712

    Derek712 Active Member

    Ok, so it's confirmed. The ethernet controller is conflicting with the USB hub somehow. When I run a speedtest while on ethernet, my keyboard disconnects 5-6 times. When I unplug ethernet and just use Wifi, everything is fine. Looks like I'm back to using Wifi until it's fixed...
     
    Cyraxus likes this.
  10. Cyraxus

    Cyraxus Active Member

    That's really annoying. I hope they know about this.
     
  11. Mindinversion

    Mindinversion Active Member

    I had this exact issue, and in my case it was the intel GPU drivers. Something about 4463 driver was causing the lag. I uninstalled and downgraded to 4424 and the windows lag went away.

    [my GPU in this case was also a 10 series card [GTX 1080]
     
    michael60617 and Cyraxus like this.
  12. michael60617

    michael60617 New Member

    I can confirm this is a fix. I was on the same version as mentioned above and downgraded to 4424 and all lag is now gone. I am also running a gtx 1080
     
  13. Cody8417

    Cody8417 New Member

    I have this issue with an RX 480 as well. found a link to the 4424 drivers, will install tomorrow. Hoping that fixes it for me too

    *Morning update, definitely looks like the 4424 drivers fixed the issue. Thanks!
     
    Last edited: Jul 16, 2016
  14. Mindinversion

    Mindinversion Active Member

    For the record, I had absolutely 0 issues with the new intel driver included with the win10 fast ring builds, but thunderbolt connectivity got so unstable I had to revert ; )

    I mention only because we're coming up on the Win 10 anniv. edition release, and it may or may not be extremely relevant soon.
     
  15. Lilacgreatvoice437

    Lilacgreatvoice437 New Member

    Just tried this morning and it worked 100%
     
  16. Derek712

    Derek712 Active Member

    What did? The older drivers or the brand new ones?
     
  17. Lilacgreatvoice437

    Lilacgreatvoice437 New Member

    The older drive solution
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >