Razer DeathAdder 2000 problem

Discussion in 'Mice and Surfaces' started by Stryx, May 10, 2016.

Thread Status:
Not open for further replies.
  1. Stryx

    Stryx New Member

    Hello, I'm new here and I joined to query and raise the problem I have:

    I bought Razer Cynosa Pro bundle (mouse and keyboard) and when I installed Razer Synapse 2.0 I started to had some issues with the mouse, ie, it is disconnected very often or stop working if i don't use it. If it helps, I have have Windows 10 64-bits

    Any solution?

    PD: Sorry for my english
     
  2. VikariousOne

    VikariousOne Well-Known Member

    Hey @Stryx! Welcome to Insider!

    Woah! What?! I have never heard or even seen this before! Is this a non-American only thing? Also, I don't know how much Insider itself can help. Insider is not a support forum and I'd have to direct you to Razer Support. I looked through the site along with the Legacy keyboards section and couldn't find this anywhere. Just try contacting Razer and see what happens.

    Best,
    Vik
     
  3. ndx_leon

    ndx_leon Member

    I think you should contact razer support directly
     
  4. i bougt Razer DeathAdder from 2013 and i can get to settings of my mouse to check dpi what i must to do
     
  5. Vivulux

    Vivulux Active Member

    As @VikasG suggested, contacting Razer Support is your best choice, as Insider isn't a support forum. http://www.razersupport.com/
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >