Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Deathadder Chroma Setting Stuck

Discussion in 'Razer Support' started by LARIMARfirstVolt743, Jul 27, 2020.

  1. LARIMARfirstVolt743

    LARIMARfirstVolt743 New Member

    Ive had my mouse for a couple years now and its worked fine but recently when I went into the synapse setting to change the lighting, it does work at all. It says i chose a different color but nothing changes and i checked the key binds and its the same issue. None of the settings actually change on the mouse when I change them in the synapse. I tried reinstalling the synapse but no luck. Any advice on solving this? Ive tried googling but have had no luck.

    The mouse also randomly stops responding for short periods of time but that's a separate issue.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >