Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Deathadder elite: dpi won't change

Discussion in 'Razer Support' started by Agentholm, Nov 17, 2019.

Thread Status:
Not open for further replies.
  1. Agentholm

    Agentholm New Member

    I have a deathadder elite and suddenly from today, it has a fixed DPI of something around 1800, which can't be changed at all in synapse software. Even if I downgrade to 600dpi to 16000dpi. It feels the same. The only time it works when I close the Synapse software. I can only see difference in DPI then.

    I've tried several method to fix this, including reinstalling/uninstalling Synapse. Uninstalling mouse from Device manager. restart. then re-install. Removing mouse from PC, using another mouse to install synapse then attach death-adder. Creating new user/profile. Nothing worked.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >