Razer Deathadder Elite sidebuttons

Discussion in 'Razer Support' started by ZezinhoOtario, Apr 16, 2021.

Thread Status:
Not open for further replies.
  1. ZezinhoOtario

    ZezinhoOtario New Member

    So, it has been a while since my side buttons haven't been working. I tried to reset my mouse and download new drivers and everything but the problem remained. The Left and Right buttons as well as the scroll work fine, but the side buttons and the middle ones dont. Can someone help me?
     
    turistainc likes this.
  2. turistainc

    turistainc New Member

    I'm having the same issue.
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey guys! Does the issue only occur when Razer Synapse 3.0 is running in the background or while logged in as a guest user? Have you tried connecting it to a different computer and check if it behaves the same? Let's fix the problem by following the steps from this link. Otherwise, send me a PM so I can assist you further. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >