Razer Deathadder v2 Pro's 2.4g mode not working.

Discussion in 'Mice and Surfaces' started by Sheikhm007, Nov 22, 2022.

  1. Sheikhm007

    Sheikhm007 New Member

    I have been using a Deathadder v2 pro mouse for like 1 year, I mostly used it in wired mode. I tried connecting the Mouse via 2.4ghz mode yesterday and it doesn't seem to work at all.(Bluetooth is working so I think the battery is fine). I tried downloading the RazerMousePairingUtility_v1.00.02_r1 From the website and it shows paired successfully but when I remove the wire the Mouse turns off even if the slider is on 2.4 mode and it doesn't blink the lights.
    When I insert the 2.4g dongle it doesn't show the name Razer Deathadder v2 pro but it adds 2 HID-compliant Mouse names. What should I do in this case? Any help will be highly appreciated.
    .
    upload_2022-11-22_20-1-19.png upload_2022-11-22_20-3-9.png
     
  2. Sheikhm007

    Sheikhm007 New Member

    And one more thing, When I connect the mouse with wire the synapse app recognizes the mouse but when I do with bluetooth it doesn't show in the app.
     
  3. FiszPL

    FiszPL Well-Known Member VANGUARD

    Right click on HID-compliant mouse -> update drivers -> browse for drivers -> C:\Program Files (x86)\Razer ther will be PIDxxxaDrv folder(s), go into that folder (in Drivers/x64 exactly), select ini file and open it - it should show which driver you'll be installing - if you've selected proper driver it'll be called "Razer DeathAdder V2 Pro" then proceed and install the driver.
     
    Sheikhm007 likes this.
  4. Sheikhm007

    Sheikhm007 New Member

    I did it and it shows The best drivers are already installed. I had uninstalled and reinstalled the synapse 3 app then it started showing the name Razer Deathadder v2 Pro when I insert the dongle but it still doesn't connect with the mouse. The mouse is working perfectly in Bluetooth and Wired connection but when I switch the slider to 2.4 mode it doesn't turn on the rgb, but the profile white light blinks after few seconds. What should I do to fix this problem ? The dongle is not connecting with the mouse like it should do.

    upload_2022-11-23_0-38-41.png upload_2022-11-23_0-39-3.png
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >