Razer DeathStalker Chroma LEDs wont work after..

Discussion in 'Razer Support' started by Strawberryhomerush091, Feb 23, 2018.

Thread Status:
Not open for further replies.
  1. Hello.

    I have this problem like, when I am turning my PC on, my DeathStalker's LED's won't work, the keys are all black and no backlight whatsoever, only Numbad and CapsLock light working (white color). Lights turning on when I unplug the USB and RePlug it.

    Windows 10 64bit
    Synapse 2.21
    Didn't have the same problem with my older DeathStalker (only green backlight)
  2. Bringing my post up, does someone knows whats up?
  3. Jenjar

    Jenjar Well-Known Member

    Odd, had the old old deathstalker like you had and I still have a Chroma one that I use time to time, never had any kind of issue like this.

    Basic things, does the keyboard work even when the lights are off for typing and such? If so, try going into synapse and try to make a new lighting profile and make sure you don't have it set to change the device lights off when the display is off, that could be a part of the issue.

    You can also try a different PC and USB ports and see if that changes anything, if it works just fine on another PC it would likely be some kind of setting you have on or the drivers on the device itself.
  4. My Razer DeathAdder Chroma and my usb chroma Steelseries headphones works how it should be, all lights starts to shine when i am turning my pc on.

    Double check'ed that, all keys working but no lights.

    Does not matter what ports, all the same. I should test it with another PC.
    Last edited: Mar 7, 2018
  5. Jenjar

    Jenjar Well-Known Member

    Thats really the last thing you can try if you tried all other ways, the best thing to do after that would be contacting Razer Support and seeing if they got a fix some way or another or just seeing if they can issue an RMA, if it is under warranty and if that would be covered.
  6. FirePenguin

    FirePenguin Retired

    ^ Trying on a different PC would be a great idea to isolate the problem. Also, what @Jenjar mentioned, we can replace it if it falls under our warranty policy.

    As another step, try downloading a new copy of Synapse and reinstalling it. Also, use a dummy account when you first log in to check if it's still not working.

    *Moving to the Support section
  7. Meanwhile, i updated my bios, didn't help, so I went to look whats going on in event logs.

    "The description for Event ID 0 from source Razer Chroma SDK Server cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Razer Chroma SDK Server
    Service has paused"
    RawUmberdailylab934 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >