Razer Deathstalker v2 disconnecting in certain USB ports

Discussion in 'Razer Support' started by soloBabyBlueEyeswatch905, Oct 13, 2021 at 10:20 PM.

Thread Status:
Not open for further replies.
  1. Hey,

    So I've had this keyboard for a while now, but recently it started acting up. When I had it plugged in to the USB port that I've always had it in, it suddenly started disconnecting at random times, not detecting inputs, getting stuck on my most recent input or just disconnecting completely, forcing me to unplug it and plug it back in.
    I tried a few different USB ports, in most of them I have this issue, in some it disconnects more than in others. Only one USB port it's perfectly fine. It's a 3.0 port, but i tried a different 3.0 port and i have that issue there too. I usually use that port for a different device with a short cable so I'd like to not have to occupy it with my keyboard.
    Could this be a driver issue? I already tried looking for new updates, but it says that it's on the newest one.

    Thanks in advance
     
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    There's a good chance that your mouse driver is not working properly. You can follow the steps on this page to fix this issue. Should the problem persists, PM me your device's serial number. I can use it to verify its model and find a different way to fix this. Let's continue from there.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >