Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer devices for Mac

Discussion in 'Razer Support' started by Wetys, Jan 28, 2020.

Thread Status:
Not open for further replies.
  1. Wetys

    Wetys New Member

    Hello, I have been using Razer devices ( Razer Deathadder Elite & Ornata Chroma ) for years.
    But I have switched from Windows -> to Mac, and have some problems with Razer Synapse software.

    So I am trying to ask here, maybe someone will know how to fix that.

    When I connect devices, basic functions works like key pressing, mouse movement and clicking etc .. but I am not unable configure them in Synapse 2.0.

    I am unable to:
    -> change key binding / unbind key
    -> change colours
    -> set mouse sensitivity

    There is no any error message.
    I have tried to troubleshoot it according to Razer website and Support, neither did work.

    It may be useful to mention, that I can see changes in Synapse, but they don't .. like "happen" on actual devices

    In general, it looks like Synapse doesn't anymore communicate with devices.
    ( Only on Mac, on PC it works with both Synapse 2 and Synapse 3 )
     
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi there! Thanks for posting your Razer Synapse 2.0 concern on our Support board. By the way, what your macOS current version? Are you using a dual boot setup on your Mac computer? Also, have you tried logging in to a dummy Razer Synapse account and check if the issue persists?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >