Razer devices not detected by Synapse 3.0

Discussion in 'Razer Support' started by Wazzi., Feb 12, 2019.

  1. Wazzi.

    Wazzi. New Member

    Hey,

    Got before razer Synapse 2.0 software and using
    Razer Kraken 7.1 V2
    Razer Ornata Chroma
    Razer Mamba TE

    Eveythink workins find detected by Synapse 2.0.
    Few days ago I got Razer Mamba Elite but herres a problem Synapse 2.0 dont support Mamba Elite.
    Installed Synapse 3.0 and wohoo 0 devices detected.
    Delteted Razer files from C:\Program Files (x86)\Razer C:\Program Files\Razer
    Reinstalled Synapse 3.0 few times.
    Uninstalled drivers, USB hubs ports.
    Clean registery.
    Unplug plug in devices and still nothing!


    I spend already around 7h with this problem and I thinking about refund that mouse to shop if I have to using this not working 3.0 Synapse!!! It should detect my all devices after plug in... what the hell?
    [​IMG]

    Using Windows 7 64bit Professional
     

    Attached Files:

    • s3.png
      s3.png
      File size:
      93.2 KB
      Views:
      16
    Last edited: Feb 13, 2019
    Taco__Derp likes this.
  2. Kpacycki

    Kpacycki New Member

    @up this same here. Windows 7 see this mouse in device manager like HID-compliant mouse not Razer Mamba. I try reinstall mouse driver's and Razer Synapse 3 and Synapse still don't see Mamba.
     
    Last edited: Feb 13, 2019
    Taco__Derp and Wazzi. like this.
  3. Wazzi.

    Wazzi. New Member

    Great to hear that not only I got this problem.
     
    Taco__Derp and Kpacycki like this.
  4. Wazzi.

    Wazzi. New Member

    Taco__Derp and LucasFur like this.
  5. LucasFur

    LucasFur New Member

    Taco__Derp likes this.
  6. off3nc3

    off3nc3 New Member

    Same issue , windows 7 . x64 Ultimate SP1
    Blackwidow Chroma Tournament v2 and Naga trinity are not seen under Synapse 3.0 , tried everything for 2 hours following every possible guide on this forum and razers subreddit,
     
    Taco__Derp likes this.
  7. LucasFur

    LucasFur New Member

    Just wrapped up with customer support ... turns out un-plugging and re-plugging the keyboard may work.
     
    Taco__Derp likes this.
  8. off3nc3

    off3nc3 New Member

    Doesn't work in the slightest , i did that and my BlackWidow TE chroma v2 just powered down all it's lights , it's working to type on but no more RBG's . just LOL
     
    Taco__Derp likes this.
  9. Taco__Derp

    Taco__Derp New Member

    same issue, ornata chroma and naga trinity, ornata not recognized or customizable but working keys and generic backlight chromatic cycling..

    Razer, please see to this prevalent problem.
    Thanks
     
  10. Taco__Derp

    Taco__Derp New Member

    uh... bump?
    bump.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >