RAZER DRIVERS

Discussion in 'Razer Support' started by paoabueg, Jul 2, 2019.

Thread Status:
Not open for further replies.
  1. paoabueg

    paoabueg New Member

    Hello, I have a problem. My Windows 10 version 1803 x64 2019-06OOB update isn't uploading and can't seem to fix it yet but below it, I can see 4 Razer Inc - HIDClass which I'm assuming would be the drivers for my 4 Razer products that I just bought. Is there any way to download them manually or to let them download first rather than the update?
    My items are:
    Razer Black Widow Chroma TE
    Razer Firefly
    Razer Deathadder Chroma
    Razer Kraken 7.1 v2 Chroma
     
  2. PT.Singer

    PT.Singer Jedi Master

    Are you thinking of uninstalling those drivers and installing them again after your update?

    If you have Synapse installed on your system, the drivers for each particular Razer peripheral should download/update as soon as you plug them into your computer and Synapse recognises them as compatible Razer devices. If you plug them in one at a time, you can control which ones download.

    Does that answer your question?
     
  3. BlackFireDragon

    BlackFireDragon Well-Known Member

    Most time simple reinstall of synapse help. Go to windows install/uninstall panel select softwere and click modify and repair should help :stuck_out_tongue_winking_eye: if this dont change anything try to uninstall all razer softwere from pc then go to appdata and programfiles folders and delete files that stay after uninstall next go to windows device menager and remove all razer devices you have and disconnect them from pc. Reboot pc and download new fresh installer from razer website and install it then connect you devices one by one. Give us know here if this help you.
     
  4. paoabueg

    paoabueg New Member


    Well, you see my update can't go through I'm not sure right now how to fix it, that's why those razer drivers aint installing. Tried 3 times already to uninstall and delete system files however it doesn't really help.
     
  5. paoabueg

    paoabueg New Member


    Yeah I did try that and tried reinstalling it 3 times, Virsualization in the synapse is working but that's about it. Can't do anything else with it. Which kinda sucks. But since you brought it up again, I will try reinstalling and deleting system files again. Cheers.
     
  6. PT.Singer

    PT.Singer Jedi Master

    Now I'm not sure whether you're talking about a Windows update, or a Synapse update. I'm moving this thread to the Support Section, in case you're talking about a Synapse update.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >