Razer Electra V2 USB randomly shutting off

Discussion in 'Razer Support' started by emu6114, Jul 15, 2019.

Thread Status:
Not open for further replies.
  1. emu6114

    emu6114 New Member

    Hi, just wondering if anyone knew a fix.
    I purchased this Razer Electra V2 USB about a month ago, when I couldn't get parts for my Krakens. But I have an issue where after about an hour of game play, they suddenly shut off. I loose both headphones and mic, and windows plays the disconnect sound. I have tried various different USB ports, updated the firmware on the headset. Uninstalled and reinstalled the drivers. Set Windows to not suspend USB devices in Power Management, and even gone into device manager and set power management to each USB root hub to not allow the computer to turn the device off to save power. I have also tried running them from an external powered USB hub to see if it was a power issue. I really don't know what else to try.
     
    stiglambertsen likes this.
  2. stiglambertsen

    stiglambertsen New Member

    Same problem with my Electra v2 usb….
     
  3. NoggeNO

    NoggeNO New Member

    Same issue here.
    Need to unplug and re-connect when it happens, which is quite annoying.
     
    emu6114 likes this.
  4. same thing happening to me i even replaced the electra v2 model with a new one from the store but even that didnt help they still cut out the audio randomly
     
    emu6114 likes this.
  5. NoggeNO

    NoggeNO New Member

    Seems to have improved after installing Synapse 2.21
    It's a bit early to tell, but haven't had the issue the last couple of days after installing Synapse and calibrating the headphones.
    Seemed like the software did some update during the installation, but not 100% sure.
     
  6. NoggeNO

    NoggeNO New Member

    Spoke too soon, issue just came back again:-(
     
    emu6114 likes this.
  7. emu6114

    emu6114 New Member

    New So the latest instruction from Razer was to disable Synapse all together, i.e shut it down via the task manager.
    Early days yet, but i managed to run 3 straight hours gaming, discord and recording on xsplit without the headset shutting off.
    I need to do some more tests, but if you guys could try that too, and see how you go.
     
  8. aparpals

    aparpals New Member

    Hi.
    And? does the issue dissapeared? because i am facing same issue...
     
  9. NoggeNO

    NoggeNO New Member

    No it haven't dissapeared fully, but it seems to have improved quite a bit, since it's not as fequent as earlier.
     
    aparpals likes this.
  10. aparpals

    aparpals New Member

    I did this also and noticed that sound still disappears but not so frequent. Problem is on my laptop and on my desktop. In general I am not so satisfied with razer products, only my razer deathadder elite works perfect.
     
  11. aparpals

    aparpals New Member

    Hello again, this solution helped me out, now headset works perfectly:
     
    Razer.SpeedCr0ss likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >