Razer Electra v2 USB surround sound problem

Discussion in 'Razer Support' started by ordinary813, Jun 15, 2018.

Thread Status:
Not open for further replies.
  1. ordinary813

    ordinary813 New Member

    Hi,
    A few days ago I've bought the Razer Electra v2 USB Headset, pretty impressed with the product so far.
    But one thing that bothers me is the surround sound, it is really disorienting, the sounds that are supposed to be in front of me are slightly behind me , and the sounds that are supposed to be behind me are really far behind me (if that makes sense). Is there any way to fix this issue? from my understanding it is the 7.1 surround.

    Thank you in advance
     
  2. ordinary813

    ordinary813 New Member

    I've figured that the issue is the surround is backwards, left is right , forward is behind.
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Yoh! Have you tried calibrating the soundstage on Synapse? You should be able to find it by clicking your Electra V2 headset on the app under Surround.
     
  4. ordinary813

    ordinary813 New Member

    I did solve it by inverting the channels but still , The sound was inverted and came from reversed directions.
    The app only allows you calibrate the sound's direction in relativity of the direction the manufacturer intended it to come from, YOU CAN'T INVERT THE DIRECTION OF THE SOUND IN THE APP.
     
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Well played! Just to check though, have you tried it on different machines just to check if you get the same inverted soundstage? If yes, I highly recommend that you have it replaced.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >