Razer huntsman elite not working after opening synapse

Discussion in 'Razer Support' started by Xvo__, May 31, 2021.

Thread Status:
Not open for further replies.
  1. Xvo__

    Xvo__ New Member

    I had the thing working for 5 minutes then I decided I wanted to change the color settings on the keyboard, but no, as soon I open synapse it stops working completely, I also reset it to factory settings so that it clears the profiles or whatever and it still doesn't work. Doesn't type or toggle things like caps or num lock, but it did default to a reactive lighting that works just fine ironically. Please help I don't know what to do.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Were there any changes applied to your system or the Razer Synapse before the issue start? Have you tried connecting your device to a different computer? Let's try to repair your Synapse first by following the steps from this link. Hope it helps.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >