Razer Huntsman mini is making my pc boot slowly whilst also making my taskbar freeze.

Discussion in 'Razer Support' started by peckzzz, Feb 3, 2021.

Thread Status:
Not open for further replies.
  1. peckzzz

    peckzzz New Member

    I just bought a razer huntsman mini and on the first day of using it, my pc now takes 20+ seconds to get past the welcome screen, in comparison to the 4 seconds it used to take. And then even when it does load, my task bar and many features are frozen and don't work, which can only be solved by restarting windows explorer in task manager. Myself and others have clarified that this issue is a firmware problem as when i try a different keyboard i have no issues at all. Many other people have this issue as well, please release a firmware update and fix this issue!
     
  2. Ackdoh

    Ackdoh New Member

    I had a Huntsman Mini too and found out that it has a bad firmware update as of November 2020 that conflicts with any AMD Ryzen system, which mine is with the 3950x. They really need to fix this (and are aware of it) soon.
     
    Eroy.gaming likes this.
  3. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Motherboard with AMD X570 socket is what seems to be causing the issue
    further investigation is required, whether it is just AMD X570 or every AMD motherboards or all Huntsman mini?

    But judging by how there are so many Insiders that have this issue, it could be all AMD motherboards. It is too soon to come to a judgment call

    We need to hear from anyone with an Intel motherboard socket to raise their voice.

    Otherwise there is the Huntsman v2 that is out now
     
    Last edited: Feb 7, 2021
  4. Solacee1

    Solacee1 New Member

    I'm using a B450 motherboard and it also happens to me.
     
  5. RickNetic

    RickNetic New Member

    razer hubtsman mini crashing my pc

    i tried the huntsman in diferents computera
    intel or amd and same issue also i contacted friends that use the same keyboard and they have same issue also

    windows hardware error
    windows explorer stop working making loging into windows pain in the ass and taskbar freeze
    gamemanagerservice.exe stoped working
    and others issue created

    any fix?
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for initiating this thread. Razer is aware of this behavior and our devs are currently investigating it. By the way, have you submitted a case to our Support Team? If you haven't, please click this link. Else, send me a PM together with your device's serial number. Let's continue from there.
     
    Horizon.. likes this.
  7. RickNetic

    RickNetic New Member

    yes i did and getting nowhere cause the agent keep asking me same question that i already answerd 100 times
     
  8. RickNetic

    RickNetic New Member

  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

  10. domz1

    domz1 New Member

    same problem here, exactly like in the youtube video posted above.
    AMD ryzen 7 5800x - b550 chipset
     
  11. RickNetic

    RickNetic New Member

  12. Horizon..

    Horizon.. New Member

    Same issue :)
     
  13. davidblj95

    davidblj95 New Member

    same issue
     
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey RickNetic! I replied to your PM.

    Hey everyone! Have you submitted a case to our Support Team? If you haven't, please click this link or send me a PM.
     
  15. Dicehunter

    Dicehunter New Member

    Been using the Razer Huntsman Mini I got a week ago and noticed upon boot my PC is VERY slow to get into Windows and the system in general feels odd, If I turn the system off, Unplug it and plug in ANY other keyboard, Oldish Corsair K65 LUX, Logitech bluetooth keyboard etc... it's fine, No slow boot and no odd sluggishness in various operations, I've done over a dozen A/B tests and the Huntsman is definitely the issue.

    Specs of system-

    Ryzen 9 - 3950X

    Asus Crosshair VIII Hero X570

    Corsair Vengeance RGB Pro 32GB 3600MHz

    MSI 2080 Ti Lightning Z

    WD SN850 NVME PCIE 4 SSD

    EDIT

    Just tried a custom made mechanical keyboard, Also equipped with USBC, No issues at all, Definitely a Razer issue, Likely to do with the keyboards firmware.
     
    Last edited: Feb 10, 2021
  16. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for sharing. Razer is aware of this behavior/ Our Support Team and devs are working on this behavior. Have you submitted a case? If you haven't, please click this link or send me a PM.
     
  17. Dicehunter

    Dicehunter New Member

    Hey there thanks for the reply, Not yet, I'll submit a ticket shortly :)
     
  18. domz1

    domz1 New Member

    I made a support ticket (*Omitted), but they are blaming my new PC because the keyboard was working on my old one (with intel cpu). So apparently not everyone at razer is aware of it...

    EDIT: my new pc has an AMD ryzen 7 5800x to be complete
     

    Attached Files:

    Last edited: Feb 11, 2021
  19. Dicehunter

    Dicehunter New Member

    Yeah there are other threads on other forums and it's only affecting AMD owners so this is a keyboard firmware issue.
     
  20. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's right. This behavior has been reported and currently under investigation. I suggest submitting a case to our Support Team by clicking this link or by sending your logs through the Razer Synapse 3.0 feedback section.

    Hi @domz1. I've sent the team your feedback. Our devs are currently investigating and working on a fix. I've seen your case history. Feel free to send me a PM should you need additional assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >