Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Installer completely broken

Discussion in 'Razer Support' started by Adomascx, Jan 29, 2020.

Thread Status:
Not open for further replies.
  1. Adomascx

    Adomascx New Member

    Hey everyone,

    A few weeks ago Synase broke for me. I through "No big deal, I'll just reinstall the software". I went to delete the program only to find that Razer Installer refuses to do so. It gets stuck in an endles loop of loading the installer (for some reason) without any effect.
    I tried searching for a solution on Razer Insider. Found nothing. Contacted support. They haven't replied for a week. So i decided to give it one last shot here.
     

    Attached Files:

  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Are you on a moderated network, and have you tried disabling your AntiMalware and Firewall?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >