Razer Kiyo not working

Discussion in 'Razer Support' started by sleekPalmLeafbus191, Sep 4, 2022.

  1. sleekPalmLeafbus191

    sleekPalmLeafbus191 New Member

    Hi, as per the title I'm having issues with my Razer Kiyo, which I had bought only a few months ago. Essentially, during a Zoom call, the light suddenly started flickering and it has never been able to capture video ever since. Whenever I unplug and re-plug, it briefly shows up on Razer Synapse, but when I click on it, the app goes blank and freezes. Then when I restart Synapse, the Kiyo module is no longer there. Similarly, in Device Manager, it's detected at first but then goes hidden when I try to use it i.e. by opening the Camera app.

    I've done a lot of browsing and haven't found much in the way of help, thus I decided to come here. I've tried all of the following, and none have worked:
    -tried different USB ports
    -uninstalled and reinstalled synapse, as well as the Kiyo webcam device + its drivers
    -updated the webcam firmware
    -checked and changed camera privacy settings
    -updated Windows
    -followed this video
    -added EnableFrameServerMode dword via regedit and setting its value to 0
    -validated all files

    List goes on, essentially I've tried everything I could think of or could find online, and again, nothing has worked so far. Any help would be appreciated.
     
    zbykowicz likes this.
  2. zbykowicz

    zbykowicz New Member

    Having same issue. Following thread.
     
  3. Nerdynursereads

    Nerdynursereads New Member

    my camera recently started flickering during recording and I don't know why. I'm using mac and recording in quicktime. I never had issues before. I'm trying to find any support to fix this issue but I'm struggling
     
  4. castgeoBlueGray852

    castgeoBlueGray852 New Member

    same issue as well my camera not working and flickering
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >