Razer Kiyo Pro not showing up in Synapse

Discussion in 'Razer Support' started by Souldead64, Apr 20, 2021.

Thread Status:
Not open for further replies.
  1. Souldead64

    Souldead64 New Member

    I've just gotten my Razer Kiyo Pro 2 days ago and it has been a struggle.
    The webcam itself works perfectly fine, but sadly it will not show up in Razer Synapse and as such I can not change any setttings.

    What I've tried so far:
    -clean installed Razer Synapse
    -uninstall and/or switched Razer Kiyo drivers
    -uninstalled all broadcasting applications
    -tried using the Razer Kiyo on a variety of different devices
    -switched USB ports
    -checked and changed the camera privacy settings of Windows 10
    -updated Windows 10 and Razer Synapse
    -validated all files

    I've also tried some more minor stuff, I've looked at every post on this forum, Reddit and a variety of other hardware forums, nothing has fixed this issue.
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    Go this way - uninstall Synapse, go to device manager - remove Kiyo Pro (with drivers), disconnect it from USB port. Download CCleaner - cleanup your PC and registry. Reboot OS. Connect camera, install Synapse again.
     
    -Siyei- and Razer.Caziel like this.
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @Souldead64 Just checking in. Has this been resolved yet? Please don't hesitate to send me a PM if you need further assistance.

    *Moved to the Support boards for visibility.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >