Razer Kraken TE Hissing during audio

Discussion in 'Razer Support' started by IamBracku, Jul 14, 2021.

Thread Status:
Not open for further replies.
  1. IamBracku

    IamBracku New Member

    I've been searching through the forums relating to a hissing noise that plays in the background of audio and after attempting many different fixes that didn't work I decided to start a thread.

    The hissing itself is based only in the right ear and on first purchase it didn't start with this hiss. To be perfectly honest I'm not sure when it actually developed. I've tried plugging it in different USB adaptors, different devices, etc. and they didn't have these issues. It was only my computer.

    I thought it might have something to do with Synapse but that didn't lead anywhere even if I fully uninstalled and everything. Neither did messing around with the chat, game or THX sound stuff.

    If anyone does actually know why this is happening please just let me know.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you updated its firmware? Have you connected the headset to your computer directly into its USB ports? Please check if the issue happens while recording your voice through Windows Sound Recorder. Feel free to submit a case to our Support Team or send me a PM should you need additional assistance. I’ll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >