Razer Kraken Ultimate not being detected by Synapse 3

Discussion in 'Audio' started by ProfessionalGamer0, Jun 22, 2022.

  1. ProfessionalGamer0

    ProfessionalGamer0 New Member

    I've been frustrated over this for the past day now, I recently got a Kraken Ultimate and while it worked for a while, I had to do some troubleshooting with the microphone, I uninstalled some drivers and then tried it again after they were reinstalled but now it wouldn't be detected by Synapse. I also tried it on another system where it still worked.
    I have tried
    - Reinstalling Synapse
    - Using the Device Troubleshoot tool
    - Scanning System Files for corruption
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    Try this:
    • Uninstall Synapse
    • Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
    • Then restart your PC
    • After reboot install Synapse again (as administrator).
     
  3. ProfessionalGamer0

    ProfessionalGamer0 New Member

    Didn't work.
     
  4. ProfessionalGamer0

    ProfessionalGamer0 New Member

    What's odd is that the audio itself works fine, however the actual software configuration is missing.
    I also noticed that if I tried using the THX Spatial Audio program to mess with it, It'd recognize it and proceed to tell me off.
    It seems to have an issue with this system in particular, as when I tried it on my laptop it worked just fine.
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Check our Device Detection Troubleshooting Tool by clicking this link. For the THX-related concern in your Razer Synapse 3.0, please perform the step from this article. Should the issue persists, please submit a case to our Support Team or send me a PM so I can help kick start a support ticket.
     
  6. ProfessionalGamer0

    ProfessionalGamer0 New Member

    It appears you missed the part where I had said I already tried this...
    I have also already started a ticket via the troubleshooting tool.
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Oh! Sorry for the oversight. Feel free to send me a PM with the case number so I can tap the team that will handle your ticket, and speed up its progress.
     
  8. ProfessionalGamer0

    ProfessionalGamer0 New Member

    I Fixed it!
    To anyone who encounters the same issue, here's how. (Under the same circumstances that is.)
    On my laptop, I noticed there was drivers there that worked.
    [​IMG]
    I went and grabbed them from "C:\Windows\System32\DriverStore\FileRepository" under the names of
    rz0527dev.inf_amd64_2df0a9f6a208d155
    rzdevu_0527_dkm.inf_amd64_7bb4ef047bb992ba
    (Varies between headset)
    Right click the inf files on the system you want the headset to work on, then select Install.
    After that it should now be recognized in Synapse!
    upload_2022-6-24_0-13-52.png
    This solution requires that you have a second Computer available.
    If you don't have a flash drive a cloud service like google drive will work.
     
    FiszPL and Razer.Speedcr0ss like this.
  9. ProfessionalGamer0

    ProfessionalGamer0 New Member

    This was likely caused by windows failing to detect if the drivers had been corrupted, so when the new ones were installed it must have solved the issue.
     
    -Mr.Nobody- likes this.
  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    What a feat! I'm glad the workaround helped. Hit me up should the issue reoccur. I'll forward this to our team as it can be a future reference.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >