razer mamba chroma wireless ( with dock) not working

Discussion in 'Razer Support' started by VioletRYBbyteportal945, Oct 7, 2020.

Thread Status:
Not open for further replies.
  1. Hello,

    im been trying to find solution for my problem over these past few days. My razer mamba wireless stopped working.

    it is detected by device manager and razer synapse 2 even the dock, the problem is everytime i plug it in it doesnt respond and the lights doesnt on. i saw a simillar problem but with blackwidow keyboard.

    can anyone help me pleeeaasse!!

    Thanks in advance
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Do you get the same results with and without Synapse running in the background? Have you tried clean installing the app and device drivers? If you haven't yet, I highly recommend that you follow this guide. If the problem persists, don't hesitate to send me a PM with the serial number of your mouse.
     
  3. Yes i tried every things,

    the mouse is detected by synapse, its like the mouse is sleeping LOL. can i pm you? ive been researching this past 3 days to trouble shoot.
    121056311_2136749819803212_2013199566460319272_n (1).jpg
     
    Razer.Caziel likes this.
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    As far as I can tell, that's a Mamba 16k. But send me a PM with the SN so I can verify the model and check for firmware solutions.

    *Locking thread to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >