Razer mamba problem.

Discussion in 'Systems' started by Alberdk, Mar 20, 2017.

Thread Status:
Not open for further replies.
  1. alberdk123

    alberdk123 New Member

    Ok so i have this problem with my razer mamba chroma. I cant click or move the cursor. When i plug it in it gets registered in the synapse program and it says that it has 100% power. It just happend overnight. i have tried several things to fixing it. What can i do to fix it?
     
  2. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Have you tried contacting Razer support about it yet? I would try contacting them and seeing if they can help you out at all :)
     
  3. DieselLag

    DieselLag Active Member

    What have you done to try and fix it?
     
  4. Sim3Gamer

    Sim3Gamer Well-Known Member

    You should definitely try to contact the Support, but also it could help to uninstall the drivers, maybe also Razer Synapse ;)
     
  5. BenjaminVien95

    BenjaminVien95 Active Member

    Hey there, if you can at least right click on the mouse than you currently have a calibration problem which needs to be addressed in synapse. Otherwise your mouse probably needs RMA.
    I have owned the mamba 2015 and mamba TE 2015. Those mice have serious sensor issues.
    I have just switched over the newest deathadder elite 2016 and that is the best razer mouse by far.
     
Thread Status:
Not open for further replies.