Razer Man O' War Overwatch, Mic issues

Discussion in 'Audio' started by raifoundnemo, Feb 27, 2017.

Thread Status:
Not open for further replies.
  1. raifoundnemo

    raifoundnemo New Member

    I just purchased the Man O' War headset today, and when I plugged it in the audio/mic wasn't working. I searched the Razer site for a solution and came up with nothing. I tried reinstalling the drivers, and the audio started working but the mic is still not working. I went into system settings and it doesn't even recognize the device being plugged in. I checked the audio ports, I even went as far as going into windows settings and trying to find the device but no luck. Any ideas on how to get the mic to work?
     

    Attached Files:

  2. Predator5

    Predator5 Well-Known Member

    Did you install Razer Synapse?
     
    raifoundnemo likes this.
  3. raifoundnemo

    raifoundnemo New Member

    I did! But that's the weird part. It doesn't even recognize that I have the headset plugged in. I even tried like registering my headset with Razer, and still nothing. :/
     
  4. Destrok

    Destrok Well-Known Member

    hmmm, looks like you need to contact support. http://www.razersupport.com/contact-us/
    a technician should be able to help you figure out if its a software or hardware issue and then take the appropriate steps to fix the mic issue. Sorry to hear about that, though honestly with the team mates I have had lately I wouldn't mind not talking to them too much XD

    anyways good luck, seeing as insider is not a support forum I will be locking the thread.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >