Razer Man O' War wired, recognised by windows but no sound/voice

Discussion in 'Razer Support' started by FunkLoad, Jul 23, 2018.

Thread Status:
Not open for further replies.
  1. FunkLoad

    FunkLoad New Member

    Bought it today. Installed Synapse.

    (Edit: Windows 7)
    Synapse updated: Check
    Drivers updated: Check
    Device set as default and default communication: Check

    I've watched numerous youtube videos and read many forum posts with similar issues but every single solution I've tried hasn't worked so far.
    Tried connecting and re-connecting several times, restarted a few times too, still no luck.

    I've used both the front and back jacks. Also tried both the single jack and the split jack (green and pink) and still no luck. I tried US and German customer support but they're closed. It's been ~3 hours of work for this new toy :slightly_sad:
     
    Last edited: Jul 23, 2018
  2. FirePenguin

    FirePenguin Well-Known Member

    Have you tried using them on a different PC or device?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >