Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Mano’war not charging

Discussion in 'Audio' started by Whiteretrodirect305, Aug 19, 2020.

  1. Whiteretrodirect305

    Whiteretrodirect305 New Member

    I have had my headset for 2 years now but out of nowhere it just stopped charging when I tried to charge it. My PC said there was a power surge so i tried to charge it in some other ways but it just didn't charge. I think it still works though because I had some battery before it stopped charging and I could still use it. Its just not charging. What should I do.
     
  2. FiszPL

    FiszPL Well-Known Member

    What other ways you've tried to charge it?
    Different USB cable?
    Different USB port?
    Did you connected headset directly to 5V power adapter?
     
  3. Whiteretrodirect305

    Whiteretrodirect305 New Member

    I tried other USB ports and cables but I don't have a power adapter so didn't try that.
     
  4. Whiteretrodirect305

    Whiteretrodirect305 New Member

    also windows gives me a message about power surge on the USB port when I try to charge it. tried to fix it by not allowing the computer to turn off this device to save power but didn't work
     
  5. Ehuds

    Ehuds New Member

    Did you ever fix it I've been having the exact same issue lately and was just going to purchase another headset
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >