Razer Nabu Watch first synchro fail Android 11

Discussion in 'Razer Support' started by Mr_BADABOUM, May 28, 2021.

Thread Status:
Not open for further replies.
  1. Mr_BADABOUM

    Mr_BADABOUM New Member

    Hi,
    I got the smartchwatch Razer Nabu Watch and I can't synchronize it with my phone on android 11.
    I've tried deco/reco Bluetooth, localization, WiFi and account. Remove it from my registed watch. Forced stop the app. Start / Stop Bluetooth on watch. Full charge it... Etc
    May the app need an update to work?
     
  2. unsponsoredgeek

    unsponsoredgeek New Member

    Same problem on my Razer Phone 2 running the present build (Android 9 February 5, 2021 update).

    "Syncing failed, please try again!"

    It doesn't sync on the Android 11 GSI or LineageOS 17.1 (HTC M8) or 18.1 (Razer Phone 1) either.

    Used to work on the LineageOS HTC M8 and stock Razer Phone 2 without a hitch.
     
  3. Please razer help us...
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you tried the steps from this link? Also, ensure that the watch is not synced to another device. Should the issue persist, please send me a PM. Let's continue our conversation privately.
     
  5. unsponsoredgeek

    unsponsoredgeek New Member

    I submitted a new ticket. I reloaded a factory image and the phone still won't pair with the watch.
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. Please continue communicating with the team. Feel free to send me a PM including your case number should you want me to check its updates.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >