Razer Naga Trinity not found by Razer Synapse 3

Discussion in 'Razer Support' started by radioRoseDustpoint329, May 19, 2019.

Thread Status:
Not open for further replies.
  1. Good evening.
    In seraching od fix for my problem with Naga Trinity I came to this forum. My new Razer Naga Trinity cannot be found by Razer Synapse 3. To this point my attempts to fix this:
    - reinstall Razer synapse (installed everything except Razer Softminer) with deleting all leftover hidden files post uninstall proces - many, many times,
    - deleting driver software for mice in Device Manager>Mice and other pointing devices,
    - trying diffrent USB ports (2 front, 3 back - working, changed with other devices),
    - disabled usb selective suspend setting in Start> Control panel > Power Options > Change plan settings > Change Advanced power settings,
    - during one of Razer Synapse reinstalls I've noticed that Razer Device Control failed to install and it repeated in next few reinstalations.
    I have WIN 7 Pro 64 bit, Razer Central Version 7.3.17.116, "no limit" in bandwidth restrictions and automated update for software "on". Everything says that mouse Device Manager sees my Naga Trinity but Razer Synapse 3 don't. I'm lost and to be honest I don't know what to do. I've read many topics with some fixes but nothing worked for me. To this point I had 2 Razer Naga 2014 and they worked, installed and were found by Razer Synapse 2 like a charm.
    I hope there is some solution to this.
     
  2. Lauriat

    Lauriat Title: Entitled

    Hi there! Has your Naga Trinity been detected by Synapse 3 before? Please try creating a dummy account, log in, and use it to check if Synapse would still be unable to detect the device.
     
  3. Marasm0

    Marasm0 New Member

    Bought my Trinity yesterday and going through exactly the same issues. Tried all the proposed solutions as well.
    Really looking forward to a solution, cause at the moment it's like a downgrade from my Naga =(
     
  4. Lauriat

    Lauriat Title: Entitled

    Hey! What were the steps you've taken so far in the attempt of fixing this? Please reply to me via PM and make sure to include the link to this thread as well. I'll be waiting.
     
  5. Hello,
    I lalready contacted Razer Support and I'm following their instructions. Got Razer test acc from them and tried it (with no succes), they asked for some info: Device & Software affected, OS Version: (full version with build number), history (When this issue start to trigger), Synapse Logs, MSINFO, SetupAPI logs and %SystemRoot%\MEMORY.DMP. After this they "escalated to Tier 2".

    Hi,
    For you and if other poor soul who wil find itself in this kind situation (hope not):

    Try to write a ticket on Official Razer Support, seriously, they don't bite. Only 500 characters so it was hard to say everything I did, but made it.
    Issue: Technical/Software, Product: Software, Product name Synapse 2 (there is no option for Synapse 3 - I just apologized for this), Your OS and Issue: Usage. Describe best as you can.
    I got response in 1 hour so look into your mail often :)
    I hope you will awesome assistance as I did, because they are really trying to help.

    Edit: Followed Razer Support instructions and it works!
     
    Last edited: May 24, 2019
  6. Lauriat

    Lauriat Title: Entitled

    Alrighty. Just give me a tap anytime you need help. :wink_:
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >