Razer Nari - Bad sound in OBS (Twitch)

Discussion in 'Razer Support' started by MaxyArthess, Mar 5, 2021.

Thread Status:
Not open for further replies.
  1. MaxyArthess

    MaxyArthess New Member

    Hi, I'm using my razer nari to stream, people hear my voice good but they hear my discord in echo, so I was wondering if anyone can help me to setup OBS / Razer to have a nice sound in my stream.

    I'm using Razer Nari - Chat as input/output in every logiciel (WoW, Discord and OBS).

    I want my stream to hear both my game and my discord, if that make any difference on the setup.

    People also hear me good in discord, without echo.

    Here a link of my twitch to see the bad sound quality:
    twitch.tv/videos/938554128

    Thanks!
     
  2. Death_Squad

    Death_Squad New Member

    Hi MaxyArthess,

    Try the steps below:

    1. Update your system OS- https://support.microsoft.com/en-us/windows/update-windows-10-3c5ae7fc-9fb6-9af1-1984-b5e0412c556a
    2. Make sure your apps are up to date. Try reinstalling the apps to make sure.
    3. Try updating your device's firmware- make sure that your device is really the Razer Nari- to prevent risk of damaging your headset- http://drivers.razersupport.com//in...ew&parentcategoryid=964&pcid=804&nav=0,78,804
    4. If you have another PC, try using the headset there and try replicating the issue.
     
  3. Death_Squad

    Death_Squad New Member

    If you're still having the issue, try doing step 4, without Synapse installed.
    You can also try using the headset without any other devices connected to your PC except your mouse and keyboard.
     
  4. MaxyArthess

    MaxyArthess New Member

    Gonna try to update razer synapse. I can't really try the others step as I don't have another PC and also the problem happens only when people hear my input/output in same time, so while streaming only. I'm gonna try to find a ways to test it without streaming as I only do this 1-2x per weeks so It's long before I can actually see the result. Would really like to have others reply about sugestion of the configuration of Razer/OBS/Discord as I'm pretty sure the problem come from there.

    Thanks for the help! :)
     
    Death_Squad likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >