razer nari loses connection with the dongle

Discussion in 'Audio' started by 5354738244, Dec 24, 2021.

  1. 5354738244

    5354738244 New Member

    hi, for a few weeks I don't know why my razer nari ultimate lose connectivity with the key every time the pc is restarted, I have windows 11 and the razer synapse 3 software that sometimes when I manage to connect the headphones does not show me on the screen the headphones of the device section even if I hear the audio. I used both the key recovery tool and the one to update the headphones and the key.Here several things happen, or the key is not in the software so I have to uninstall the driver and also change the USB port or sometimes it recognizes it but the firmware download goes to the maximum and then returns to zero and asks me to restart the firmware download (when I open the application, version 106 of the headphones appears while in the key section the current installed version does not come out, practically as if was installed). In summary it is as if the pc deleted the driver of the key at each reboot (I have already reinstalled synapse 3 several times) what can I do to solve?
     
    LosMentos, smokecigarettes and mdias_ like this.
  2. smokecigarettes

    smokecigarettes New Member

    Sad to see this is still happening.

    Have talked with support multiple times, reinstalled both windows, and synapse multiple times, the dongle tool, uninstalls, nothing seems to work consistently. This also happens when connecting to my macbook pro.

    Is there truly no fix for this issue?
     
    BR3ADLOAF and LosMentos like this.
  3. LosMentos

    LosMentos New Member

    I have the same problem with windows 11 :slightly_sad:

     
    BR3ADLOAF likes this.
  4. RyanStrong1234

    RyanStrong1234 New Member

    Also having this same issue, seems to have started since windows 11 update. I have updated drivers for xbox wireless adapter.
     
    BR3ADLOAF likes this.
  5. I am also having the same issue. Windows 11 as well.
     
  6. GOBIC_ROY

    GOBIC_ROY New Member

    jesus christ RAZER are you guys even willing to solve this issue? bought a 200$ nari ultimate that worked perfectly fine and you guys won't make it available for windows 11 even though we already have A LOT of people experiencing the same issue.
     
  7. sharf224

    sharf224 New Member

    I’ve had this non stop with multiple windows 10 PCs, reinstall, and with my RMA replacement.
     
  8. jota2nove50

    jota2nove50 New Member

    I have win10 and i have the same problem...
    it´s a very expensive headache
     
  9. ohyababy

    ohyababy New Member

    I use win10 ,i buy blackshark v2 pro,and i have the same problem...
    makes me feel very unhappy
     
  10. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Important note; Blackshark V2 pro dongle is different compared to Nari dongle

    Do not mix them together~~~

    Have you tried updating both the Windows and Synapse 3.0?
    Have you tried reinstalling the Synapse?

    If nothing works, send a DM to one of the official RAZER support
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >