Razer Nari Ultimate charging problem

Discussion in 'Audio' started by EgeOKC, Jan 30, 2019.

Thread Status:
Not open for further replies.
  1. EgeOKC

    EgeOKC New Member

    Hello guys i bought a Razer Nari ultimate today everything is very good until i want to charge my headphones.
    I tried to charge my headphone but my computer make usb unplug-plug sound while playing a game.
    My spec:
    i7 8700k
    32 gb ram 3200mhz
    RTX 2080 ti zotac
    1050 watt PSU
    z370 auros gaming 7 edition
     
    EchoOnYoutube and 0V3R_K1LL like this.
  2. ChiefNieth

    ChiefNieth Active Member

    I have the same issue with my ManOWars...
    Someone let us know if ya'll got a fix!
     
    EchoOnYoutube and DRIFT_IT like this.
  3. EgeOKC

    EgeOKC New Member

    I am using a ipad adaptor right now and there is no problem playing game while charging the headphones now.
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    For sure this is usb power delivery issue when the port get xx of power windows shutdown and restart the usb port. Tehre is multiple fix guide on gogle. In simple you must go to usb hub controler and change there in dropdown menu to the do not disconnect or do not shoutdown this port or something like that :) This will fix the disconnect 100%
     
  5. LukeSkyballer

    LukeSkyballer New Member

    I was having the same issue. I have my front panel back panel filled plus a usb card filled. I then installed to a seperate powered usb hub and I don't have any issues any more charging while playing. I guess the Nari's are power hungry.
     
  6. BlackFireDragon

    BlackFireDragon Well-Known Member

    It depends what power supply you have and what you have plugged on your machine :stuck_out_tongue_winking_eye: Everything take power so when you get high demend of power to charge device when other hardwere take to work it power split in case of charging this give low power to fill battery :)
     
    ProjectOgira likes this.
  7. freshCopperRose635

    freshCopperRose635 New Member

    Hi, I'm having this issue with a 1300 watt PSU.

    8700k, dual titan maxwells, 2x16 TridentZ sticks, and some fans.

    I don't think it's the power issue... but I could be wrong

    Hi, Actual fix here....

    Not usb hub, not PSU issues,

    Go to razer synapse while your charging your headphones and turn OFF haptic sense. Enable it when you're done charging.
     
    Last edited by a moderator: May 15, 2019
  8. BlackFireDragon

    BlackFireDragon Well-Known Member

    Lets start with simple explenation how headset work. Nari headset is not a wirless/wired change mode device what this mean is headset always take power from battery and must be plug via usb dongle or jack 3,5mm to work with this second connection nothing change still headset take power from battery not from wire. @freshCopperRose635 yes haptic feedback with few other settings enable can take more power then battery can charge and give you this issue but in first place like you can read before in this post people know this can happend the same thing you can have in any other device. When you write charning people understand you have headset off in other case it's great to write in the issue you try to charge with headset on. Remember one thing not always this can be a issue for any other person becose there is many other things that can give you the same issue.
     
    mega47 and HN1936D09000486 like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >