Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

razer nari ultimate dongel recognized as Avnera av 6301

Discussion in 'Razer Support' started by aha099, Feb 4, 2020.

  1. aha099

    aha099 New Member

    Hi,
    My razer nara ultimate is not working, the dongle is recognized as Avnera av6301.
    Tried the dongle recovery tool, but get "no action required"(https://support.razer.com/articles/1588406641)
    Also tried pairng the headset again, and get that the dongle needs updating, but any attempt to update fails.

    Brgds
    Asbjørn
     
  2. G_Leland

    G_Leland Member

    Hello Sir.
    You should reconnect dongle, until your pairing tool will recognize your dongle.
    It can take a lot of time.
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Have you tried uninstalling the drivers that pop up on the Device Manager when you plug in the dongle? If the problem persists, please PM me the serial number of the headset.
     
  4. Emriss97

    Emriss97 New Member

    Hey there, I'm having the same problem since a couple of days. I searched for a solution but everything I tried didn't help at all. Neither the recovery tool nor uninstalling the uppopping driver did change a bit. I'm not a computer specialist so chances that I didn't do everything properly are quite high.
     
    Last edited: Mar 26, 2020
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Allow me to help you troubleshoot if not further isolate the issue. Please PM me the SN of your headset. That way, I can validate the model that we'll be working on. Let's go from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >