Razer Nommo Chroma speakers suddenly not working?

Discussion in 'Audio' started by lesbianhentai, Jul 16, 2021.

  1. lesbianhentai

    lesbianhentai New Member

    Hello¬ Im just wondering if anyone could help me?
    I bought these speakers about two years ago and they were working perfectly fine until a few days ago. Ill push the on button on the speakers and theres the clicking noise but no sign of power despite it being plugged in properly both into the jack point and the back of the speaker.
    Ive tried different power points and checked my USB and still nothing. Theres no sign of damage to the power plug and cords either?
    I think I might just need another power connection but the problem is I live in New Zealand and can't seem to find a replacement anywhere. I could buy an american powerplug for the speakers but then Id have to use a converter and New Zealand has higher voltage so Im not sure about the longevity of that setup.

    The speakers are no longer in Warranty so I cant use Razers official support to help :/

    Any ideas or links to where I could buy the power plug would be must appreciated :heart:

    The original power adapter/plug
    https://razercarestore.razer.com/razer-nommo-power-adapter/


    [ Some basic specs ]
    FREQUENCY RESPONSE 50 Hz - 20 KHz
    INPUT POWER Ext. Power Adapter
    DRIVER SIZE - DIAMETERS (MM) 2 x 3" full range drivers (1 x per speaker)
    DRIVER TYPE Custom woven glass fiber 3-inch drivers for power and clarity
    COMPATIBILITY 3.5 mm connection
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >