Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Opus paired but don't connect ( multiple platforms)

Discussion in 'Razer Support' started by masielpeguero, Jun 9, 2020.

  1. masielpeguero

    masielpeguero New Member

    Hello all! I am new, this is the first razer product I own. I've gotten myself the new Razer Opus. I started using them with my XBOX using the 3.5mm audio socket, and they work well. With the Switch as well. I tested with Android phone using audio socket and they also work. I do not have the adapter to test with iOS but I imagine using audio socket it will work.

    Here comes the problem. When pairing the headphones to Windows and Chrome OS they paired but never connect. Blinking blue pairing mode light stays ON. On Windows, I can see the device recognized on the Device Manager but disappears almost immediately. Chrome OS do not see them at all.

    I gave Linux a try (debian) and the pairing process fail. I've paired Microsoft keyboard/mouse, Jabra headphones with Debian and it works flawlessly, therefore I got to say Razer Opus are the problem here.

    I paired the headphones to a macbook pro, successfully! look at that! At this point I am very disappointed because the headphones are expensive and too engineer to not be supported in these platforms. You would think it will work given the price/specs/ and competence out there. Anyway, very disappointed.

    I decided to check the official guide, https://dl.razerzone.com/master-guides/OPUS-en.pdf, and wasn't surprise it only reference Android and iOS. If they are indeed not supported on windows(mainly) using Bluetooth, I guess I proved it; but I do not want to believe that. Even checked support page to see if proprietary drivers where needed for Windows but nothing.

    So here I am, I am looking for other users that own a pair of Razer Opus. What is your experience using the headphones (Bluetooth) So far? any hiccups?

    I can do plenty of testing since I have the devices available. Feel free to recommend anything.

    I opened a case with Support since I bought Razer Care, I will update when I hear from them.

    Thank you very much!
     
    pancholr likes this.
  2. ADeadGunslinger19

    ADeadGunslinger19 New Member

    Hello I just got a new pair today. Did the firm ware update and all that. But every time it pairs the phone recognizes it as paired however the light keeps blinking
     
    pancholr likes this.
  3. masielpeguero

    masielpeguero New Member

    Hey! how did you do the firmware update? Can you provide me with a link to downlod it - steps?
    I want to try it to see if it helps with the original issue on this thread that I reported.

    I looked in the downloads on the razer site and they do not have a firmware update listed, maybe I am looking in the worng place? I appreciate if you share with me what you try.

    Thank you
     
  4. ADeadGunslinger19

    ADeadGunslinger19 New Member

    It just prompted me when I got the app.
     
  5. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member


    Hey there! Thanks for posting your concern here. Were you able to get an update through the Razer Opus app? Feel free to send me a PM should you need additional assistance.
     
  6. Sandalfon74

    Sandalfon74 New Member

    I have the same issue with my computer. It works with my mobile phone but when I try to pair it with my computer I see 2 razer option in bluetooth: Razer Stereo and Razer Opus.
    Razer Stereo is listed as "Other devices" and can be paired but it doesn't do anything, whereas Razer Opus is recognized as an Audio device but the pairing always fails with the error "can't connect to the device, try again"
     
  7. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! Thanks for sharing your Razer Opus concern here. Have you tried selecting the "Razer Opus Stereo" as your playback device? If in case it didn't help, please clear your Windows Bluetooth sync history and try pairing the headset again.
     
  8. Same issue here, I also reinstalled my bluetooth device, doesn't help. Now windows cannot even see Razer Opus anymore, it can only recognize Razer Stereo, connecting to which, once again, does nothing at all.
     
  9. Just bought my pair and have the same issue - Razer Opus doesn't appear on the list of bluetooth devices. tried connecting to Razer Stereo against the instructions and it does nothing
     
  10. Cruel-Angel

    Cruel-Angel New Member

    Same issue. It works perfectly with my iPhone, but Razer Opus doesn't appear on the list of bluetooth devices on my Macbook Pro. Tried resetting the Bluetooth Module and clearing the sync history, turns out other bluetooth devices work without problem, but the Razer Opus is still not appearing.
     
  11. Just got mine also. Has the same problem. Already had a problem with razer Bluetooth earbuds before. This is quite disappointing as there are no solution.
     
  12. masielpeguero

    masielpeguero New Member


    Well, I did the firmware upgrade when I got the headphones. They do not work with windows. They only work with iOS, macOS, Android (sometimes so far).

    The issue still persist, and it is the same described the original message.

    I paid for support and I haven't gotten any replied yet which is very dissapointing.
     
  13. masielpeguero

    masielpeguero New Member

    It does not work with Windows. It will pair but not connect. For some users it does not show under the BT list. I have tried test on 4 windows machines and the issue is the same. This headphones are not compatible with Windows. Very dissapointing.
     
  14. ZorakD

    ZorakD New Member

    Good news-- I THINK I HAVE A FIX!
    I had this exact same problem today. I bought the headphones at launch and paired them with my Blade with no issue. Today, I unpaired and wanted to connect them to my iPhone. I downloaded the app and did the firmware update. Nothing worked after that. I was getting all the same issues, the useless "Razer Stereo" connection if I tried to go back to the PC, and it was showing up as "connected" in the bluetooth on my iPhone, but only when the Opus app was open. There was no "i" with a circle around it like my other connected devices.
    But here's what worked: put the device you want to connect to in AIRPLANE MODE. You can still leave bluetooth on, and I can confirm the device both instantly connected to my Blade and my iPhone. I was able to use both and switch back.
    I'm guessing the firmware updates introduced some kind of bug, as I certainly didn't have this problem on the launch firmware (without the app).

    Hope this helps!
     
    Last edited: Aug 2, 2020
  15. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey ZorakD! Thanks for sharing. I'll forward this to our team.

    Hi everyone! Please check ZorakD's post. Should the issue persists, please send me a PM or submit a case to our Support Team by clicking this link. I'll wait for your feedback.
     
  16. BL00DLocK

    BL00DLocK New Member

    I have encountered the same issue. They connect to my Razer Phone 2 no problem. But when I attempt to connect to my PC it simply gets paired, but never registers as a usable audio device. That's when connecting to Razer Stereo. Attempting to connect to Razer Opus just doesn't work.

    I tried the solution offered by @ZorakD but it did not work. Having a read back through it though it likely connected to your blade instantly due to it being a Razer product?

    I hope this is fixed soon. Shipping delays have made me wait extra long for these and I've been using broken headphones up until this point.
     
  17. BL00DLocK

    BL00DLocK New Member

    Hi everyone. I have a fix for PC (this will also work for your phone). When you power on the headset and it makes the sonar noise as it is trying to connect, continue to hold down the power button as your PC searches for a bluetooth device. Your headset will not power off, but this will now connect properly as Razer Opus should pop up automatically as an audio device you can connect to.

    Worked for me first time.

    I hope this solves everyone's issue!
     
    mheeinhale and Razer.SpeedCr0ss like this.
  18. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for sharing! You can also see the step on this link under the "How To" tab. Feel free to update this thread or send me a PM should you need additional assistance.
     
  19. mheeinhale

    mheeinhale New Member

    Solution from BLOODLock work like a charm, Thank you!

    To Razer, please see if you can fix this issue without having user doing band-aid solution. Cheers!
     
  20. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! Thanks for confirming, but this is not a band-aid solution. You can see that step here. Cheers.

    upload_2020-8-9_3-6-6.png
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >