Razer Opus X won't turn on

Discussion in 'Razer Support' started by DarkCoralxbuzz511, May 19, 2022.

Thread Status:
Not open for further replies.
  1. DarkCoralxbuzz511

    DarkCoralxbuzz511 New Member

    Yesterday i bought brand new Razer Opus X. all day it was fine. i could connect them, listen to music, etc. later i turned them off and after 2 hours when tried to turn them on, they just doesn't react. they was charged (80%), but anyway i tried to put on charger and it didn't work. light indicator not working at all.

    i found that Razer Opus (not X) has reset function, but i didn't find if Razer Opus X have this function. need help please,

    Thanks in advance
     
  2. Razer.Zionzedd

    Razer.Zionzedd Yes, My lord? Staff Member

    Try to press and hold the power button until the status indicator starts blinking blue. It's recommended to fully charge the headset before using it for the first time. Perhaps the battery was drained, did you try to charge it for at least 3.5 hours? If that didn't help, it's most likely a hardware problem. Feel free to check our self-help if you have questions or PM me anytime should you need further assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >