Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Phone 1 (Cheryl) LineageOS Installation Guide

Discussion in 'Mobile' started by Rox598, Jul 1, 2020.

  1. Rox598

    Rox598 Keyblade Master VANGUARD

    Hey insiders!

    I wanted to do an updated guide on how to get LineageOS installed on your Razer Phone 1. I will try to make this guide as simple as possible.

    *****Warning this guide will void you warranty******

    *****I nor Razer are responsible for any bricked devices, you do this at your own risk*****

    Step 1: Download the required software

    LineageOS (Always download the latest build) You will also require the recovery image for the first install so download both the ROM and the Recovery Image.

    Gapps (Google apps such as Google play store. Choose "ARM64> Android 10> Choose Nano)

    Google USB Drivers (You will need these if you haven't flashed anything before)

    Platform Tools (we'll use this for flashing the actual software)

    That's all that's needed! make sure they're all saved to the desktop. Now you have these downloaded it's time to get your phone ready.

    Step 2: Getting your Razer Phone Ready

    The following steps will wipe your phone! So please backup any data before you do this

    *Open your phone's settings and scroll all the way down until you see "System"

    *Enter the System settings and select "About Phone"

    *Scroll down until you see "Build Number"

    *Tap on "Build Number" repeatedly until you see "You are now a developer" appear on the screen.

    *Press the back button and tap on the "advanced" option to reveal other options

    *You should see "Developer Options" listed, Enter it.

    *Make sure "Allow OEM Unlocking" is on and "USB Debugging" is on

    Step 3: Unlocking The Bootloaders

    Now your phone is ready it's time to get the PC and the Phone communicating with each other.

    *Open the "Platform Tools" Zip file and place the folder on your desktop.

    *Now connect your Razer Phone to your computer

    *Make sure your phone has a notification saying "USB Debugging Connected" when connected to the PC

    *Open the "Platform Tools" Folder

    *hover your mouse in the contents of the folder and hold down the "shift" Key and right click.

    *You should see options appear one of which will either be "Open Powershell here" or "Open command line here" click it and a window should appear.

    *Now type this command into the window for Powershell ".//adb reboot-bootloader" Without the quotes. If you're using Command line (windows 7, 8) it's "adb reboot-bootloader"

    *When you type these commands make sure your phone is on, it will ask if you trust the computer, select yes.

    *Your phone should now be in it's Bootloader, Hurrah!

    *Now your phone is in it's bootloader we need to make sure Platform tools can see it. hover your mouse over the windows logo and right click.

    *Open the "USB Driver" Zip file and place the folder on the desktop

    *Select "Device Manager"

    *When Device Manager is open, look for a little yellow Triangle over the Android device.

    *Right click it and select "Update Driver"

    *From here select "Browse My Computer" > Let me pick> Show all devices

    *In this menu select "Have disk" then select "Browse"

    *In here, navigate to the desktop and find the "USB_Driver" folder. Click it and press "Open" Twice

    *Press "Okay"

    *Now a menu should appear with 3 options "Android ADB Interface" "Android Bootloader" and another, select the top one.

    *Now the device manager should show the phone as an "Android ADB interface"

    *Close device manager you won't need it again

    *Go back to the powershell/Command prompt again

    *Now type .//fastboot flashing unlock for powershell or fastboot flashing unlock for command prompt

    *You phone should display a warning, ignore it and select "unlock the bootloader" using the volume keys

    *Your phone will reboot and wipe itself, wait for it to boot fully before doing anything else.

    *When your phone boots into the user setup screen unplug the USB from the bottom of the phone and switch it off.

    *Hold the volume down button and re-insert the USB cable. Keep holding the volume down until you see that bootloader screen again then let go.

    *Now go back to the Powershell/Command Prompt and type for powershell ".//fastboot flashing unlock_critical" or for command prompt "fastboot flashing unlock_critical"

    *You should see that same warning screen on your phone again, use the volume buttons and select "unlock bootloader"

    *Let your phone reboot like last time then shut it off again and repeat the actions to get it back into it's bootloader by holding the volume down button and inserting the USB cable.

    Hurrah your phones bootloader is now fully unlocked! Phew! Go get a drink!

    Step 4: Flashing Lineage


    Now it's time to get that sweet LineageOS onto your phone! this will be the last step! easy, right?

    *Drag and drop the LineageOS Zip, Open_gapps Zip and Lineage-17 recovery image into the platform tools folder

    *Right click on the "Lineage -17 recovery" file and select "rename" rename it to "boot"

    *Now open that powershell/command prompt window again and type " .//fastboot flash boot boot.img" or in command prompt "fastboot flash boot boot.img"

    *the command line should say finished after installing

    *now on your phone select "recovery mode"

    *on your phone you should now see a recovery menu with the lineageOS logo! yay!

    *on your phone go down to "factory reset"

    *when the reset is done go back and select "apply update" >"apply from ADB"

    *Now go back to the powershell/command prompt and type .//adb sideload and type/copy paste the full file name followed by .zip and press enter.

    So for example it'll say .//adb sideload lineage-17.1-20200627-nightly-cheryl-signed.zip

    For command Prompt it'll say adb sideload lineage-17.1-20200627-nightly-cheryl-signed.zip

    *Now you'll see on screen it'll flash the software to your phone, wait until it finishes (sometimes it'll stop at 40% and ask you on the phone if you trust it, select yes and leave it. it may look stuck and may give you an error but it will still flash)

    *When your phone shows that that step is finished select "reboot" and let the phone boot up to you see the LineageOS setup wizard (the first boot might take a bit) and then switch it off and go back to the bootloader then to the recovery menu again


    *select apply from ADB on the phone again then go back to the powershell/command prompt and type ".//adb sideload <file name of the gapps package here> .zip

    so it for exmaple will say .//adb sideload open_gapps-arm64-10.0-full-20200630.zip

    Wait for that to flash (you'll have to press yes on the phone again also during the flash)

    *When the gapps is finished, factory reset the phone again and then reboot

    You're Done!!



    Now you should have Lineage OS installed on your Razer Phone 1 :D

    Some details to note

    The phone is stuck permanatly in 120hz without being able to change it
    Builds are available every 7 days but is subject to change

    If you have any issues with any steps please comment below and i'll help as much as I can.


    -Rox
     
    Last edited: Jul 1, 2020
    pancholr and ZiCott like this.
  2. munsened19

    munsened19 New Member

    Thanks for this! I've been eyeing the new builds for the RP1 but it's been a long time since I flashed a phone OS. This will be super helpful when I finally make the jump.
     
  3. ZiCott

    ZiCott Member

    I guess this means no more official updates from RAZER for RP1...=(
     
  4. Honestly how are the Razer Phones, just asking that is people that have personally used one, owned one, and/or firsthand experienced one, please any response, I will acknowledge the opinion and my total perception and satisfaction for Razer as a whole honest;y is at a 100 and the scale I am using is 1-100?! Anyways, just wondering because if great I'll have to invest in one, two, or 5, lol?! THANKS!
     
  5. Munsened

    Munsened New Member

    I've had a rp1 since launch. Had to replace 1st under warranty for defective touch screen. Second has been going strong for 2+ years now. Really happy with the phone. Only gripes other than lack of updates are that screen does wash out in bright sunlight and the stock camera app is just ok.

    But honestly I've had an rp1 since Nov. 2017 and feel no need to replace it anytime soon. As I mentioned above I'll likely jump to lineage is sometime soon just so I can stay updated with Android and security patches. Though if Razer even just did security patches I probably wouldn't even bother with lineage.
     
  6. I can't get Step4 - "*Now open that powershell/command prompt window again and type " .//fastboot flash boot boot.img" or in command prompt "fastboot flash boot boot.img"" to work... I get the following errors (see attached screenshots).

    After some googling I tried "Fastboot flash:raw boot boot.img" but then it's just stuck at "Sending 'boot' (23573 KB)" indefinitely. Any idea?

    **UPDATE** Found the solution. Use "flash:raw boot_b boot.img" in command prompt. If that doesn't work, try "flash:raw boot_a boot.img". Big thanks to the official guide - https://wiki.lineageos.org/devices/cheryl/install
     

    Attached Files:

    Last edited: Sep 23, 2020 at 1:28 AM
  7. Munsened

    Munsened New Member

    Yeah, I had the same issue but ended up doing the "fastboot flash:raw boot boot.img". First computer I tried on with regular USB port and USB A to USB c cable didn't work. Second computer with USB c port and original phone cable and it worked. Read that the stock bootloader is finicky and you basically just have to keep trying.

    Side note: latest build from 9/19 has a bug were phone app won't work. Can't hear or say anything. 9/12 build works flawlessly so far though.
     
  8. Oh man, thanks for including the sidenote...I thought I was the only one cuz I couldn't find anyone else posting about it. I just found that out today, trying to listen to my voicemails lol Was about to give up on LineageOS completely.

    Btw, did you get Google Pay to work? I tried using Magisk but it doesn't seem to trick google lol
     
    Last edited: Sep 24, 2020 at 4:59 PM
  9. Munsened

    Munsened New Member

    Instead of flashing the nano gapps go with micro or mini (I did mini). When I tried nano I had zero google apps. Micro or mini (I flashed both previously) will give you a working play store plus whatever other apps come in the package. Only potential downside (I don't care but you might) is that micro and mini come with pixel launcher which replaces default lineage one.
     
  10. Ohhhh I was actually using "Full" Gapp lol Google play works fine, but Google Pay doesn't work. I can't get it to setup contactless payment because it says my device is modified or something. If I downgrade to 9/12 build, does that mean I'll have to wipe my phone again?
     
    Last edited: Sep 24, 2020 at 5:37 PM
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >