Razer Phone 2 - Android Auto issues

Discussion in 'Razer Support' started by BPMOmega, Feb 9, 2019.

Thread Status:
Not open for further replies.
  1. BPMOmega

    BPMOmega New Member

    Hello! I just got the Razer Phone 2 a couple of days ago, and am already loving it.

    Though, there's one significant issue I've been having with it. Android Auto in my car (2016 Honda Accord) will not detect it at all via USB. While it can connect to my car's Bluetooth just fine, USB is required for Android Auto in my car's dash.

    For point of reference, my phones prior to this were Moto X (3rd gen) and LG G6. The Moto X would connect to Android Auto without any issue. The LG G6 had... some issues, but it'd still work most of the time. Every now and then, my car wouldn't detect it (only fixed by restarting my car). Even when it did, it would always have message pop-up that said something like "Unknown device" (but would still boot up Android Auto anyways).

    With the Razer Phone 2... nothing. My phone is definitely receiving a charge through USB, but there's no detection at all of a smartphone being connected.

    I've tried uninstalling and reinstalling Android Auto on my phone several times. Rebooted it several times. Nothing's changed (also, worth noting that Android Auto seems to crash a lot on the Razer Phone 2... hmm).

    Any suggestions? I kinda wonder if the issue is related to the switch to USB type-C, seeing how the G6 (also type-C) had some issues while the Moto X (MicroUSB) didn't. Perhaps it needs a software update from Honda or something?
     
  2. Rox598

    Rox598 Keyblade Master VANGUARD

    Android Auto unfortunately is a mess of an ecosystem. There's not a single forum you can go to which has people having an issue with it in some way shape or form.

    That being said are you using the cable that came with the razer phone to connect to your car? Also are there any notifications about a usb cable being connected? Sometimes when a usb is connected Android will ask what you want to use it for and it's default setting is "charging" if you tap that notification you'll get more options.

    Lmk if this doesn't work and I'll see what other options we have.
     
  3. BPMOmega

    BPMOmega New Member

    Thanks for the quick reply, Rox!

    I couldn't use the cable that came with the phone, since it's USB-C to USB-C. My car has a USB-A port built in.

    Yes, the USB notification does come up when plugged in. Interestingly enough, my car's dash did display an "unknown device" pop-up when I tried the PTP and MIDI options (but nothing when I tried the "transfer files" option).
     
  4. Rox598

    Rox598 Keyblade Master VANGUARD

    No problem :)

    you have the android auto app installed (stupid question I know but just to be sure)

    I also have a couple more things you can try to see if we can get you up and running.

    1. Go into the developer menu (if you don't know how to do this to to system settings>system> about phone and tap the build number 7 times) you should see a pop up saying you are now a developer. Go back one screen and you should see developer options. in there activate USB debugging (Option 13) and change the default usb connection to MTP (option 28) and then try and connect to your car.

    2. Try another usb cable. The one you're using could be stopping your phone detecting the phone properly.

    Again lmk if either of these works or doesn't so we can continue troubleshooting.
     
  5. BPMOmega

    BPMOmega New Member

    Yeah, the app is installed (hey, I get it; gotta check EVERYTHING when troubleshooting!).

    1. Enabled USB debugging, and the default USB connection was already set to MTP.

    2. Tried another cable, still nothing. First one was some random brand I bought off of Amazon (Sabrent), second one was from Nintendo.
     
  6. Rox598

    Rox598 Keyblade Master VANGUARD

    Damn I was hoping the first option was the fix :slightly_sad: looking through all my sources and the last thing I can find to do is to try and change the USB settings in developer menu from MTP to "Audio Source"

    I think if this works it needs to be manually chosen every time you reboot the phone but I'm not sure.

    If this doesn't work lmk and I'll get someone from the support team to reach out to you and I'm sorry I couldn't be more help. Having never used Android Auto my knowledge is a bit low.
     
  7. BPMOmega

    BPMOmega New Member

    Sadly, changing to Audio Source didn't get a response from my car's dash, either. I've tried every USB option (even Supply Power, because why not), and nothing.

    Even if we haven't gotten it working yet, it's all part of the troubleshooting process. So, I appreciate your help, anyways. :)
     
  8. Rox598

    Rox598 Keyblade Master VANGUARD

    Damn! :slightly_sad: My last option would be if you could wait for the next system update and see if that fixes the issue for you. Android Auto is a real mess.
     
  9. FatKidWanderer

    FatKidWanderer Well-Known Member

    Hello, @BPMOmega ! Allow me to assist you with this further. Can you send me the serial number of your Razer Phone 2 through PM? Let's continue from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >