Razer Phone 2 + Android Auto?

Discussion in 'Mobile' started by Ringowu1234, Nov 28, 2018.

  1. Ringowu1234

    Ringowu1234 New Member

    Can anybody confirm if Android Auto works on their RP2?

    I couldnt get my RP2 to work but Pixel 2 XL works, same cable, same car.
     
    pancholr likes this.
  2. xDanger65

    xDanger65 Member

    Yep, It works in my '17 ZL1. It took probably 8 install/uninstalls, but it finally works. Idk what changed. I literally just sat there and messed with it until it behaved. Waze sometimes crashes in AndroidAuto, but I had that happen on my note 8 too, so I don't think its an RP2 specific issue.
     
  3. Rox598

    Rox598 Well-Known Member

    Android Auto is one of those things that is so so damn difficult to deal with. Search any Android forum for device and I guarantee that you'll see posts about phones not connexting to cars properly etc

    Basically Android Auto is a mess. But if you try to connect it again and it fails feel free to take a bug report, upload it to Google drive and I can take a look see if I can find the issue.
     
    ThirdTemple likes this.
  4. defante01

    defante01 New Member

    Worked for me in my '18 Honda Odyssey. Only used it once so far though just to test it out. Navigation worked just fine.
     
  5. ThirdTemple

    ThirdTemple Member

    Wireless Android Auto or are you guys using USB?
     
  6. defante01

    defante01 New Member

    USB for me.
     
  7. Ringowu1234

    Ringowu1234 New Member

    USB. I ended up leaving the "old" Pixel 2 in my car connected (car break-in is not a thing here in Taiwan), and built an automation task to tether internet from the RP2 whenever I get in car.

    I actually prefer this method since the phones and car just do their own without me doing anything. My wife can just enable Bluetooth tethering on her iPhone when she gets into car and the Pixel will automatically connects to it
     
    Last edited: Dec 1, 2018
  8. RazerWeasel2

    RazerWeasel2 New Member

    Hello,

    I am having the same issue. 2017 Camaro SS. The phone will connect to the car through Bluetooth perfectly, but Android Auto requires a USB connection. Android Auto sees the phone just fine. Navigation and alerts work fine. Android Auto sees my Google Play Music account and all of my playlists. Audio from the phone will not play through the car speakers. If I press play on the Android Auto screen the music starts to play through the phone. Pressing any audio controls on Android Auto controls the phone. Also, if I use the car's standard audio setup that uses Bluetooth audio plays through the car speakers. My Note 9 works just fine with Android Auto. My Asus ROG phone works just fine. Previous Android phones worked just fine. This is even my second Razer Phone 2. I had to exchange because of another issue. Seems like the issue is a software setting that I just cannot locate.

    Paul
     
    directzoneMint529 likes this.
  9. ThirdTemple

    ThirdTemple Member

    You know if this approach:

    https://forum.xda-developers.com/ge...droid-3-0-proxy-gateway-android-auto-t3813163
     
  10. Ringowu1234

    Ringowu1234 New Member

    Yea it's similar to what I did, would've gone this route if I read it earlier. Instead of wifi I used Bluetooth tether, which I think is more energy efficient for the source device?

    Either way, I highly recommend this if you feel comfortable leaving an old Android device in your car. I even downloaded offline maps in Google map, so navigation still works when internet is not present.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >