A Flagship lineup. The next generation in Gaming. Join us live on stream this October 10th, 2018, for a special unveiling event. Exciting news. Stay Tuned.

Razer phone with Bluetooth car audio

Discussion in 'Mobile' started by VerdankG, Jan 20, 2018.

  1. xRuhRohx

    xRuhRohx Member

    I am frustrated by it not connecting to my car too. I don't think their update actually did anything wrong. It just advanced the BT software beyond what is in the cars. Every other BT connection still works just fine. We just have to wait for them to figure out how to give us the advancement but still dumb it down for non smart car radios.
     
  2. Darksteel165

    Darksteel165 Member

    Non smart car radios? Do you have any idea what you are talking about?
    I own a 2018 Silverado with a Bose stereo system and a GM head unit that has Android and apple carplay along with BT and nav.

    BT worked fine pre update (on 8.1) they did an update labeled as a bugfix with the only new feature being the some worthless camera filter and now BT doesn't work.
    So yes. They did something wrong.
    I want some of whatever you're smoking
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hey there @VerdankG ! I sent you a PM so I can help you with this. Check your inbox and get back to me if you still need help.
     
  4. xRuhRohx

    xRuhRohx Member

    Cool you want to be insulting, then your first problem is that you have a Chevy. When you want to be a civilized person and discuss this properly maybe we can find a fix or figure out how to work with Razer and get the issue resolved. But complaining and throwing a fit isn't going to fix anything. It was a software update. No hardware was broken. They will fix it. Just have to be patient. It really is not that complicated. Plug your phone into the aux port and wait.
     
  5. VerdankG

    VerdankG New Member

    Since I started the thread in January, I have had almost no problems with connecting my Razer phone to my BT radio system in my car. After roughly 4 days or so it just started working.

    I have no idea why, I literally can not give any answer to you other than it started working. I have had all of the current Razer phone updates installed and have ran into absolutely ZERO problems with them. I'm sorry to see that this thread has gotten out of hand recently.

    I would like to say thank you to RedPanda, who has contacted my personally about this asking if I had resolved the issue or was still having problems. There's no need for these posts to turn hostile, you're all in the same boat or are trying to help in some way, and I'm sure the staff are looking into this.

    I'll do my best to give you all any information I have on how mine suddenly started working, please just reply and I'll be sure to keep my eye on the thread from now on.
     
  6. Thermos

    Thermos New Member

    On my 2015 Nissan, I started to hit this that it is near unusable in the car now. Steering wheel or dash controls no longer work even when I get it to connect so this became a safety hazard. I have to manually force a connect now as others have already mentioned too. Before 8.1, this worked without issues. It autopaired and had full functionality. I have yet to reset Bluetooth via the System stuff nor a factory reset but really? This should be working with a reboot if anything.
     
    Last edited: Jun 3, 2018
  7. FritzCT

    FritzCT New Member

    Well said Verdan…And just to add my penny worth, whilst they don't yet seem to have a fix I've found the support to be very responsive.

    TBH I think this may be two different issues (or maybe a hardware issue after all). It seems it's the 8.1 MR1 update that's caused this for many but your original post pre-dates that. In fact in Jan 2018 you would have been running 7.1.1. Could I ask if you are now running the recent May update (8.1 MR1 Build 5037 or 5038)?

    Personally I'd be happy to simply flash back to 7.1.1 (Razer developers site has the image files to do so) but I'm not going to do that at the expense of my warranty.

    Anyway Razer support are clearly looking into this so whether it's a hardware or a software issue I'm sure they'll find a resolution. We just have to hang in there for while I guess.
     
  8. Nerruza

    Nerruza New Member

    Whelp, took me a fair old while but coming from the latest software and back flashing the OPM1.171019.011-RZR-180329.4054 factory image (without factory resetting) and then clearing the bluetooth service apps data / cache I am now able to successfully pair and playback music in my van. :wink_:

    Still.. I was intending to keep this phone 100% stock to avoid issues exactly like this from custom firmware / kernels. Having to unlock the bootloader and plow through hours worth of tech documents and forum posts in order to fix something broken by an official update isn't how I like to spend my free time.o_O

    I could write up a guide on how to revert to the previous version of Oreo without factory resetting but encouraging users to void their warranties (in some countries) and potentially turn their phones into bricks in order to fix an issue caused by an official update is ludicrous.

    Hopefully Razer releases a fix soon!
     
  9. FritzCT

    FritzCT New Member

    @Nerruza Glad it worked out...and it's another indicator that the issue is with 8.1 MR1 so hopefully Razer support can hone in on that.

    I know what you mean about the tech documents and stuff. I've had a read up (just in case) and whilst it looks do-able it's not exactly entry grade stuff. Seems there's a real risk of bricking if it goes wrong and, of course, then the warranty is probably void.

    My latest response from support is that they have confirmed that they are aware of the issue and that a fix should take no longer than a month. I know that's longer than we all want to hear but even as open source there must still be some QA/ approval needed, even if only from Three in my case.
     
  10. Spike7447

    Spike7447 New Member

    so, i was having an issue where the music would play, but it came through really choppy. so, i updated the firmware on my car stereo and it fixed my problem.
    mine ended up not being a phone issue at all....
     
  11. ButteryGSP

    ButteryGSP New Member

    :c
     
  12. Darksteel165

    Darksteel165 Member

    This sounds like a completely different issue.
    Our problem is the connection to the radio not quality of the connection.

    Glad your problem is fixed but this doesn't have anything to do with ours (my 2018 has current firmware per the dealership)
     
  13. Just want to add that I'm having the same exact problem... Used to connect perfectly fine to my 2015 Cadillac, stopped after the most recent update.
     
  14. Darksteel165

    Darksteel165 Member

    Yep update for May broke BT on our phones.

    Razer support still has no update no information.

    Make sure you open a case and keep contacting them every few days so they don't leave our phones broken...
    Shoulda got another Samsung or a Google phone...
     
  15. Barton71

    Barton71 New Member

    Had exactly the same issue ever since the update after the 8.1 update. Contacted Razer support and they suggested setting the Bluetooth AVRCP to 1.5 or 1.6, which made absolutely no difference. They then suggested a factory reset, which also made no difference what so ever. They have now sent my fault report to their "update team" to review. Haven't heard from them in over a week now.

    It's even more annoying because everything was working perfectly before an update which is supposed to improve the performance of our handsets.
     
  16. hgv1970

    hgv1970 New Member

    Have been going through with Razer support on this matter since the end of May

    1 was try a soft reset (Nope)

    2 Factory Data reset ( Nope on the BT problem but caused other problems like phone crashed every time you went to use camera and SD card wouldn't read and had to be reformatted then it reformatted it at double the capacity so after about 3 more Factory resets it was back to just the BT problem)

    3 Remove all paired devices and turn BT off and on reset car bluetooth (Nope)

    4 Clear the Phone BT cache and data (Nope)

    5 Pair with the Bluetooth device.
    Try connecting the phone to another Bluetooth device using the process stated above
    •If the phone connects to a different device, the Bluetooth device you are trying to pair may be defective or incompatible.
    •If the phone does not connect to a different device, proceed to the next step.

    6 Disable Battery Optimization1.Open device Settings and click into the search box and type “Special app access”.
    2.Then tap “Battery optimization”
    3.Click the drop-down box and select “All apps”
    4.Scroll down and select “Bluetooth MIDI Service”
    5.Tap and select “Don’t optimize”

    7.Reboot into Safe Mode1.Safe mode is a nice way to identify Bluetooth issues, in case they are caused by the third-party apps. Safe Mode disables third-party apps (runs your phone without any third-party apps) and hence can help you identify mischievous apps. If Bluetooth works properly in safe mode, then it means that a third-party app is causing problems. Uninstall recently installed apps or the ones that you suspect. Reboot your device and see if it helps.

    8 Perform a hard reset and test the phone again.

    9 If the issue persists, backup your phone data and perform a factory data reset.

    10 Change the AVRCP Version1.Open the Settings app
    2.Tap on System
    3.Tap on About phone
    4.Tap Build number about 7 times
    5.Tap the back button
    6.You should now see Developer options under Backup and above System update
    7.Look for “Select Bluetooth AVRCP Version” under developer options and try each one of the different settings, i.e. AVRCP Version 1.3, 1.4, 1.5 and 1.6

    Now awaiting the next decision really hope they work out this glitch in the update soon
     
  17. FritzCT

    FritzCT New Member

    Guys, I'm still speaking to support about this and they seem to be suggesting that this is isolated to Three branded phones, which isn't my understanding.

    Please could anyone with this issue confirm whether they have a Three branded handset or direct from Razer.

    Cheers

    Fritz
     
  18. Rsgc90

    Rsgc90 New Member

    I am on Three
     
  19. hgv1970

    hgv1970 New Member

    I am on Three too
     
  20. Barton71

    Barton71 New Member

    I'm also on Three.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >