A Flagship lineup. The next generation in Gaming. Join us live on stream this October 10th, 2018, for a special unveiling event. Exciting news. Stay Tuned.

Razer phone with Bluetooth car audio

Discussion in 'Mobile' started by VerdankG, Jan 20, 2018.

  1. Nerruza

    Nerruza New Member

    I'm using global images.
     
  2. Darksteel165

    Darksteel165 Member

    What do you mean Three branded?
     
  3. kdogguk

    kdogguk New Member

    Three here too. I've been looking for help on XDA too.
    Is there no way to rip the Bluetooth settings from the 7.1.1 image and replace the 8.1 version?
    Surely Razer must have changed something there to break it
     
  4. hgv1970

    hgv1970 New Member

    In the UK the Razer phones are exclusive to the provider Three and come up with the logo when the phone boots.
     
  5. FritzCT

    FritzCT New Member

    I guess if you cook your own ROM that's possible (although I haven't the faintest idea how that's done) but then you need to flash the custom ROM and lose the warranty. It would probably be a better idea just to flash back to 7.1.1 in which case you still lose your warranty but don't run the risk of flashing a custom ROM. A custom ROM using the 7.1.1 BT may not solve it either. As far as I know the patch that seemed to cause this was a security & camera patch so I'm guessing it's the security part that's gone wonky.

    This is the message I got from Razer support

    "The issue is affecting Three's phones. Currently we are investigating together with their developers, which may take a bit longer than solo investigation, because of delay in updates between the parties."

    So it may not be something Razer have done, maybe it's Three's tweaks that are the issue but then at least one person here is using global images. Going to start harassing Three anyway just in case.
     
  6. Darksteel165

    Darksteel165 Member

    Nope.
    I'm in the US and I have a unbranded Razer phone direct and I have the same problem so saying it's a problem with a branded phone is bull.

    Just to be clear BT worked fine on 8.1. it was when they released the first bugfix after 8.1 it broke.
    You guys on Three may of been placed directly on the bugfix version after we got both updates.

    It was the May but fix that broke BT so we would only need to revert whatever change was done there (not 7.1).

    As of yesterday Razer support claims they found the problem and are working on it but it's been over a month after they broke our phones so not sure I have faith in them as a company right now.
    Guess it was my fault for buying their first phone and not staying with a good phone manufacturer.
    I figgured for $800 cash we would of gotten a good working unit and good warranty support.
     
  7. FritzCT

    FritzCT New Member


    Yes, correct. Three skipped the MR0 update and so we went from 7.1.1 MR3 directly to 8.1 MR1 (the May bug fix)
     
  8. Yep I'm on three UK too, and I have this issue with car Bluetooth but auto connects to my removable satnav every time no probs. #weird
     
  9. FritzCT

    FritzCT New Member

    That's quite interesting.

    Personally I have this issue with all BT connections whether the device is new or old.

    Would you mind posting the make, model and software version of your removable satnav. I've sent the link t this thread to Razer support several times so if they are monitoring the info may help them.
     
  10. Nerruza

    Nerruza New Member

    All my Bluetooth devices worked perfectly on the latest version (Mi Band 2, Mi Speaker, FM Transmitter, Rodimi FM Transmitter, Motorcycle Headset, Sony Bluetooth 3.5mm wireless) except pairing with Mercedes, VW and Ford head units for media or calls. I could only replicate the issue with automotive bluetooth devices.

    Pretty sure Razer are well aware of this issue by now. I mean, we've narrowed it down between two versions for them and highlighted which bluetooth devices are most effected.
     
  11. hgv1970

    hgv1970 New Member

    Just tried connecting my phone to the Bluetooth system of one of the works trucks (Mercedes Actros) and all the song information comes up on the screen and the pause skip functions work but no audio. Yet on my car (Nissan Juke) I get the audio but no information and controls.
    Not sure how the Bluetooth system works is it possible that it should be making two connections one for audio and one for the information/controls and it is now after the patch it only makes one?
     
  12. kdogguk

    kdogguk New Member

    I have managed to fix my problem of the device not playing music through the car Bluetooth stereo.
    There is an option in the settings menu of each device (tap the cog icon next to the Bluetooth device)
    Deselect HD Audio. Now my phone plays music and allows voice calling through the car stereo.
    I had to be connected to the device for the check boxes to not be greyed out.
     

    Attached Files:

  13. Yeah it's a Garmin drivesmart 50 dlt , much better than the built in car satnavs in my opinion :0)
     
  14. Darksteel165

    Darksteel165 Member

    What are you running?
    I have never had that option

    These are my options and unchecking or checking doesn't change anything.

    My phone used to work on 8.1 update 0 and on 8.1 update 1 nothing works.
    2018 Chevy Silverado (8 inch mylink with nav)
    2016 Chevy Silverado (8 inch mylink without nav)
    2014 Chevy Equinox (8 inch mylink without nav)
    2014 Kia Optima Uvo (factory head unit)

    All factory installed systems.
     

    Attached Files:

  15. FritzCT

    FritzCT New Member

    I don't have that option either. I'm currently stuck on 8.1 MR1 (the Three version).

    I have:

    Phone Calls
    Media audio
    Input Device
    Contact sharing

    Selecting/ deselecting makes no difference.

    I've tried many different devices, new and old, including factory fitted & third party head units (some with latest firmware some with old), a HP & an Asus laptop, an Acer tablet, Damson bluetooth speakers, and a Blaupunkt TV.

    I have the issue with them all.
     
  16. Darksteel165

    Darksteel165 Member

    I'm also on 8.1 mr1 but I'm in the USA with a unbranded phone.
     
  17. Mikeynaz

    Mikeynaz New Member

    I'm on 8.1 mr1 unbranded in Canada, bought from the Microsoft store. Bluetooth stopped working when the latest security update was applied last month. I'm driving a 2014 Chevy Silverado. Please fix this already!
     
  18. Darksteel165

    Darksteel165 Member

    Open a support case.
    Razer doesn't read these threads only users.
    I have had a case open for over a month with no technical support provided.

    If it's brand new return to Microsoft and get a phone from a company that supports their product.
     
  19. kdogguk

    kdogguk New Member


    I'm on the latest 3 UK release. 8.1
     

    Attached Files:

  20. Runnerxs

    Runnerxs New Member

    The issue is with the codes. The latest update is using AAC by default, switching to SBC will get it working. You can do this in developer options, Google it if you want to use them. Unfortunately the setting doesn't stay selected and you will have to switch it every time you connect to the radio.
     
    NikiforosH likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >