Razer Products freezing until restart

Discussion in 'Razer Support' started by Yosaras, May 11, 2019.

  1. Yosaras

    Yosaras New Member

    Hello,

    so i basically own a deathadder elite, a blackwidow chroma and a goliathus chroma extended, what happens is that at random times like in game or even when i am afk at desktop everything kinda stops working. lightning changes to some random static and mouse and keyboard keys are dead while my computer still runs perfectly,

    for example when that happens in game i can still see in real time what's going on but i can't act. If i were to guess probably some synapse thing or maybe sth with the install went bad along the way cos it actually appeared out of nowhere without me updating anything.

    the only thing i've tried so far:

    repaired the installation of everything razer related. worked for a couple of days or i was lucky.

    anyone had this issue before? any idea what i'm dealing here with?

    thanks in advance for your replies.
     
  2. DaRicket

    DaRicket Member

    I am kind of having the same problem. I am using the Razer xbox turret on windows 10 and when the keyboard is plugged it I have no problems but on wireless I get a weird purple LED color then it will block to whatever I have it set up to then back to purple and I get crazy input lag until I turn it off or unplug the dongle. I have tried everything I can think of to fix it. Factory reset, turning off all power save modes. Shit is pissing me off.
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Are you still having the same issue? It might have been a bug with the installation of Synapse. Which version are you using?

    Hello. Can you send the serial number over to me through PM? I'll pick it up from there.
     
  4. Yosaras

    Yosaras New Member

    Hello, i am not sure if anything got udated but as of now my current version is 3.4.415.41818
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Just to clarify, are you still having the same issue or has it gone away after the repair?
     
  6. Yosaras

    Yosaras New Member

    no the issue stills persists like it actually just happened, another thing to add which i tried earlier today is that even if i unplug them and replug them it surprisingly doesn't do a thing, not even plug sound like they never existed.
     
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please send over the serial number of your devices through PM. Include the link to this thread as well. Let's continue there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >