Razer Raiju Tournament Edition stuck on bootloader

Discussion in 'Razer Support' started by bitstreetOrangePeel426, May 13, 2022.

Thread Status:
Not open for further replies.
  1. Greetings! I recently recently update the Razer Raiju Tournament Edition(ps4/pc controller) from firmware
    1.05 to 1.06. The updater didn't really install anything, it just stopped, but now the controller is sort of bricked.
    It is stuck on "Razer Bootloader" according to both of my windows (win7/win10). I tried with different firmware updaters (v1.06.00 r1, v1.05.00 r2) and nothing, it says that my controller is up to date (but it is bricked) no turning light, nothing. I also tried to reset the controller, with the back hidden button and also nothing.
    I really don't know what else to do.
     
  2. Razer.Zionzedd

    Razer.Zionzedd Member Staff Member

    Did you check if the controller was in USB mode? PM me the serial number and a copy of your receipt so I can validate its warranty and forward your case to our RMA Team for a replacement request. I will lock this thread to curb our conversation privately.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >