Razer Ripsaw HD black screening / fps dropping

Discussion in 'Razer Support' started by Vobluda, Aug 21, 2019.

Thread Status:
Not open for further replies.
  1. Vobluda

    Vobluda New Member

    Hello Razer community!

    I've started setting up my new streaming setup with the Razer Ripsaw and have encountered an issue, where my OBS on my streaming PC experiences frame drops and black screens from the Ripsaw HD.

    My streaming PC is an Acer Predator Helios 300 2018 (https://snlookup.com/acer-predator-g3-572-notebook-nh-q2bec-001-p143281#ffs-tabbed-16). It's plugged into the USB-C 3.1 Gen 1 port using a Dell USB-C to USB-A 3.1 adapter.

    I have Synapse installed, so the correct drivers should be installed.

    I've tried just hooking up the Ripsaw to my beefier Gaming PC with higher level USB ports, and it worked like a charm there, but it just doesn't seem to work on my laptop, no matter what port I connect it to.

    Is there any possible fix to this issue I'm having? The Ripsaw advertises itself as a USB 3.0 capture card, so it should be compatible with my laptop. It's quite an expensive purchase for me, so I'd be pretty bummed out if I couldn't use it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >