Razer Ripsaw not being detected in OBS

Discussion in 'Razer Support' started by Volc0241, Jul 18, 2018.

Thread Status:
Not open for further replies.
  1. Volc0241

    Volc0241 New Member

    For whatever reason my Razer Ripsaw is no longer being recognized in OBS anymore. My computer recognizes it as an unspecified device and still outputs to my screen, just not to OBS. I have already checked that OBS and my capture card are all up to date. I troubleshoot my device and even uninstalled and reinstalled everything and still nothing. Out of desperation I installed Xsplit and it recognizes my capture card I just can't use it in the free version of Xsplit. I tried Streamlabs OBS as well and that doesn't recognize it either. So I can't find the source of the problem and I am all out of ideas.

    Any and all advice is appreciated.

    Edit: The problem has resolved itself, after using the device on another computer I discovered that it wasn't the Ripsaw or OBS but in fact my desktop itself, though I didn't figure out what exactly was the cause, a factory reset of my desktop seemed to have reaolved all issues.
     
    Last edited: Jul 21, 2018
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Do you have Synapse installed? If so, have you tried doing a clean uninstall of Synapse?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >