Razer Ripsaw ps3 problem

Discussion in 'Console Peripherals' started by RyuuguuAlphard, Dec 10, 2017.

Thread Status:
Not open for further replies.
  1. RyuuguuAlphard

    RyuuguuAlphard New Member

    Hi. I've been trying for a few days to connect my ps3 to this game capture but all my effort was in vain. I have both of the settings set to 720p (OBS and ps3) and the ''no signal'' screen of horror is shown in OBS. I have everything connected and I've been researching quite a lot but nothing works. The ripsaw works just fine with my ps4. Could anyone help me? Maybe it's the region? I'm a bit lost. I used another game captures but it was easy to use them, just connect and go. Thanks in advance.
     
  2. jampy00

    jampy00 New Member

    Hiya, I was having the same issue and found your post. From what I find online the issue is the HDCP simply put this blocks recording devices. You can turn HDCP off in the PS4 but with PS3 there is no such option. Many people say the use of a HDMI splitter will fix this issue, I use a HDMI splitter and still have the issue. I sad to say any "fixes" may only work for some..
     
    RyuuguuAlphard likes this.
  3. RyuuguuAlphard

    RyuuguuAlphard New Member

    Thanks for replying! I also tried a couple of times a HDMI splitter and doesn't work for me. I hope the two of us find a solution fast. I contacted Razer support already and they told me to reinstall everything but still nothing. If I achieve something, I'll inform you right away.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >