Razer Ripsaw stays red

Discussion in 'Razer Support' started by lorddannyy, Jul 8, 2020.

Thread Status:
Not open for further replies.
  1. lorddannyy

    lorddannyy New Member

    Hello, I have tried looking for the fix for this issue in various places and could not find anything to work.

    I just got a used razer ripsaw and after setting it up i noticed that the light turned red. After installing all of the appropriate software (Namely synapse 2.0) the program updates but the light remains red. I have tried uninstalling all drivers and razer programs on my computer and restarting it multiple times.

    When looking at the ripsaw in the device manager tab I get the following error:
    "This device cannot start. (Code 10)

    Insufficient system resources exist to complete the API."

    I am running windows 10 x64 bit processor.
     
  2. mharlhowne

    mharlhowne New Member

    agian!, it's actually sad when you purchased something from them and they gonna leave you behind with some issue... bad support! I have the same issue it work for me all of a sudden but i forgot what did i do before it happend unfortunately i bought a new laptop and I still got the same problem, i hope you have solved this and would love to hear how... thanks in advance!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >