Razer Ripsaw Video/Audio Freezing

Discussion in 'Broadcaster' started by NoSide, May 27, 2016.

Thread Status:
Not open for further replies.
  1. Hello everyone, I just hooked up a razer ripsaw to my W10 machine and set it up with OBS standard, added it to a global source and added the GS to a scene.

    When previewing the stream the rip saw shows up 50% of the time and when it does show up, the video freezes then the audio stops.

    I have uninstall Synapse and reinstalled but no change.

    Is there anything else I can do?
     
  2. Im having an issue where the audio crackles and than everything freezes. Have you had any luck?
     
  3. sirwolfart_no_id

    sirwolfart_no_id New Member

    same here!! i have keep refresh the card plus i get screen taring. i am using xspit broadcaster and its up to date. i have a laptop with i7-4700MQ, 12gb of ram this is where i stream from razer ripsaw. i am using the hdmi input on the ripsaw at 1920x1080 come from my main pc.

    ok i updated xspilt and now i can see the fps of the incoming video. when the the video starts taring the fps drops 2 to 4 fps and when the video freezes fps drops to 0.
     
    Last edited by a moderator: Aug 4, 2016
  4. Hey,

    Just an update - I configured my video output when right clicking on the ripsaw from X-split and adjusted it to 720p - I than adjusted my connected device to 720p and Im not experiencing the issue.....Not ideal but its working for now.
     
  5. sirwolfart_no_id

    sirwolfart_no_id New Member

    i have tried that and that does not help
     
  6. Konzen_no_id

    Konzen_no_id New Member

    Hi guys, I've been searching high and low across the internet for a solution to this and the one that worked for me was buying a USB 3.1 PCI-E Expansion Card Adapter. I've got one like this but there's a lot of brands out there.

    This problem is not only limited to Ripsaw but other capture cards that uses the USB 3.0 slot. From what I've read this happens mostly to people who are using older motherboards which has the early releases of USB 3.0 controllers.

    TLDR - If you're using USB 3.0 and your capture card stream/recording freezes after a random amount of time and you need to refresh the source, get a USB 3.1 PCI-E Expansion Card Adapter.

    Hope this helps. No guarantee it'll work for everyone but I've tried everything out there and this worked for me! been recording for hours with no issues now!
     
  7. Junch

    Junch Associate Product Manager Staff Member

    Hi @NoSide could I trouble you to provide me your OBS log files so we can take a closer look at your issue from our side?

    Thanks.
     
  8. It also happens to xsplit and my CPU specs are i7 5930x, MSI x99AC, 32GB DDR4, on M.2 Hard Drive. The PC should be capable of streaming without freezing I've tried everything please HELP!!! This is very annoying having to refresh all the time while streaming...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >