Razer Surround

Discussion in 'Razer Synapse' started by urbanGreenSheendepot099, Jan 5, 2018.

Thread Status:
Not open for further replies.
  1. willyyoung

    willyyoung New Member

    Try to start Razer Synapse by Right Click>Run as Administrator then go to the Setting and manually check for update

    With Razer Surround the music is much better!
     
    Last edited by a moderator: Feb 1, 2018
  2. spiv4kl

    spiv4kl New Member

    all ok now , nice to see it all working
     
  3. pasildan

    pasildan New Member

    Just came to report. It's working perfectly gentlemen. Thank you a lot Razer surround developers, the experience is great thanks to you. My sub-woofer really feels better now.

    Wow buddy, would appreciate a lot if you can share more of those tracks. It's oustanding, an additional plus because rocks so hard with my sub-woofer. Thanks for sharing.
     
    Last edited by a moderator: Feb 1, 2018
  4. DjRealm96

    DjRealm96 New Member

    You peeps mind letting me know what you did? My Synapse still showing as version 2.21 and Razer Surround Pro is still missing from the list to even pick. Though it's still listed as option over system that I'm using it.
    All that's showing up in Synapse for me is my DeathAdder...

    Just tried reinstalling Surround, nothing. :slightly_sad:
     
    Last edited: Jan 16, 2018
  5. luizmp

    luizmp New Member

    My Synpase asked for and update... fixing M$ slip-up from last week... but still 2.21 too... it's working cuz I removed the Windows Update... but strange isn't?
     
  6. Everything working fine after synapse update! My razer surround is back.
     
  7. i keep checking for updates through synapse, its saying im up to date but my headphones/surround still isnt showing up? Do I have to reinstall?
     
  8. No, I simply clicked ‘check for updates’ and the option to install the patch appears. After install completes, synapse show my deathadder elite and surround pro
     
  9. Did that multiple times, and it always says im up to date. Tried to reinstall it and now it wont open. It shows the icon in the bottom right but when i click it to open the window, nothing shows up...
     
  10. Try to reboot system and after icon appears, there should appears on screen ‘syncing with cloud’ after a while. Until that is complete, synapse will not open
     
  11. luizmp

    luizmp New Member

    But the most painfull problem is still there... the "primary device" changes every reboot... I have 1 Headphone and use an "Audio Mixer Application " called VoiceMeeter Banana ... and Razer Synapse keeps changing from my Headset to VoiceMeeter everytime... it's annoying... Already asked for Support but they said that there were my ppl with the same problem, but no solution until now.... :slightly_sad:
     
  12. I had a similar problem fir a long while now. Had to manually select playback device every boot up. A real pain in the a@&!
     
  13. MaximumBunny

    MaximumBunny Well-Known Member

    You can use a program like Audioswitch for that. Sound software always messes up something. I lost the ability to listen to audio in browsers while one software was open.

    You have to pick and choose. It's not something exclusive to Razer Surround. :)
     
  14. Bean10

    Bean10 New Member

    Yay! It's here now. Just updated and Razer Surround is fixed! Thanks Razer!
     
  15. SlickXzX

    SlickXzX New Member

    Having the same issues. But synapse won't even show my headset with surround installed too. Don't get it at all. I had this issue after intel's CPU update to fix the meltdown virus and what not. Very f*cking annoying!
     
  16. Grovah

    Grovah New Member

    Windows broke it again for me after an update...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >